Disconnecting and reconnecting?

Discussion in 'General Discussion' started by TheShykid_, May 15, 2021.

  1. TheShykid_

    TheShykid_ New Member

    Hey!

    so I recently just finished my dream razer setup with Blackwidow keyboard, basilisk mouse, kraken kitty headset and goliathus mouse pad.. I updated my computer and my synapse right after connecting everything and it worked fine in the start but then it started disconnecting and reconnecting.. all of it.. and the headset is making a popping sound.. I have no idea what it is at all! Please help :/
     
  2. -Mr.Nobody-

    -Mr.Nobody- Active Member

    most likely software issue. there is same problem somewhere here. cant remember tho which one the original post. what i can tell you is. this is gonna be little bit hustle. and sorry for your 1st razer device to have this problem. before you start to do this make sure you have spare mice and keyboard to use.

    download uninstaller cleaner - most of insider using ( ccleaner ) to clean all your registry leftovers after you uninstall program.
    uninstall synapse.
    go to search box and type device manager
    and uninstall all razer device manually - on device manager there is listed all your device that have been connected to your PC. for example mice. click mice option and drop down you will see razer device from there.

    after you uninstall your razer device ( mice, keyboard, headset, etc that you have. open your cleaner and clean from registry. once you finish all that. dissconnect all your razer device and restart your PC.
    once your pc ready re install synapse 3 and then re connect 1 device at the time. and let synapse do the work. remember 1 device at the time,
     
    Proteas and pancholr like this.
  3. thakyZ

    thakyZ New Member

    I tried this, and it still doesn't work, I am glad I am not the only one who has been getting this because then it isn't an issue with my computer necessarily.

    I have a Razer Kitty Kraken and have been having this issue for quite some time. Furthermore, I have tried getting a replacement, which has worked for some time, and then eventually it ended up happening again.

    I have also done some debugging, and it appears that the USB device just straight up disconnects from the computer and then automatically reconnects. So maybe it's an issue with the headphone's themselves.

    I have tried using my headphones extensively on my phone to get no issue at all. Then I tried not using them for about a week, and upon giving them another chance, they started to not pop every second, but as per usual it started happening again, and I still cannot find any issues of what is going on with them.

    This is rather annoying, and I almost want to think it's some issue with THX Service or Razer Synapse 3. But I am unsure. I have tried to contact Razer support but every time I don't get much help, which is fine because I am sure they are understaffed because of the pandemic. But other than this I am not sure.
     
  4. -Mr.Nobody-

    -Mr.Nobody- Active Member

    have you tried run without the software or run ur pc into safe mode ?
     
  5. thakyZ

    thakyZ New Member

    I just tried safe mode, and it still apparently happens, I am confused as to what it is still, but I guess Razer Synapse is out of the question. Though there does seem to be an issue with my model of Motherboard X570 and the previous one I had which was B550, and they are getting their issues solved via BIOS updates, but so far with the help from MSI no luck yet.

    I would like to mention it appears that when I go to move the wire at the base of the headset or the top of the USB plug it does not cut out, so it's not a wire issue.
     
  6. -Mr.Nobody-

    -Mr.Nobody- Active Member

    this is very interesting, how many troubleshooting have you tried ?
    would you mind to breakdown here. so i dont have to double explained something that you have tried
     
  7. thakyZ

    thakyZ New Member

    Well double explaining wouldn't be a problem. But what I have done is I tried for quite a while my headset on my phone and it seems fine, no disconnecting or anything.

    I noticed that the THX audio device at time just straight up doesn't work. So I go and fiddle around with it by restarting Razer Synapse and disable the device while doing so. It seems to *sometimes* work after that, but then there is still the issue of the Razer Kraken device disconnecting every so often, which I still think is the fault of my Motherboard but I am still not sure, as the updates that supposedly fix the issue on my motherboard don't seem to work.

    I have also tried to reinstall Windows and Razer Synapse.
    I also tried to go and uninstall Razer Synapse uninstall all drivers. Then unplug all devices. Then inserted a non-razer keyboard and mouse and reinstall razer synapse after a restart. When reinstalling I log into Razer and then go to the update section and I plug the mouse in first. Which I let it update and then I click update, and I do that with every device up to the headset. And still it likes to disconnect even then.
     
  8. foxyfate

    foxyfate New Member

    This is what I previously commented on another post with the same exact issues.

    Unfortunately this HAS to be a Razer Synapse software issue. I've been dealing with the same exact issues for over a year now. I've had my whole computer checked out and there was not an issue. I uninstalled and reinstalled Razer Synapse many times (also uninstalled all my Razer devices) and nothing, still disconnected and reconnected. I treated my headphones with so much care and Razer Support labeled my problem as a hardware issue and sent me a new pair of Razer Kraken Kitty Editions. Now the new pair worked for a few months (like 2-3 months) and then they started disconnecting and reconnecting again. I've tried a lot of troubleshooting and to be honest Razer doesn't see a problem with their software. There's been threads left open with no solutions from Razer for years now. The only time the headphones work and don't disconnect is when Synapse is uninstalled. But then why pay all that money for something you don't get any of the benefits for? It's very frustrating. So if anyone has any other solutions I'm willing to try but at this point I'm about to get new peripherals because the disconnect and reconnect is so frequent... ALSO for anyone contacting Razer Support you will need a video of the headphones (or any other peripherals) disconnecting and reconnecting. Best of luck for everyone with this issue, I understand how frustrating it is!
     
    Jageros likes this.
  9. -Mr.Nobody-

    -Mr.Nobody- Active Member

    now im positive this is software issue. you have tried everything and the result are the same,
    i was thinking maybe the cabel is broken turns out you doing just fine when you connecting with your phone, the other thing is usb port problem ( you can try this if you have different pc or laptop.

    the software issue is beyond my knowledge. i wish to help you until its fully fixed but i cant >.<
    if you still have a warrant i could ask for an exchange, who nows mightwork
     
  10. foxyfate

    foxyfate New Member

    Yeah it's just an unfortunate issue with certain devices. I believe it might have something to do with the RGB syncing or chroma studio maybe? My boyfriend has Kraken tournament headphones (I think that's what they're called) but they don't light up and he doesn't have these issues. It's very frustrating because for me they can go from a week without disconnecting but then somedays it'll do it every 2 minutes. I really don't understand (but I'm not a big tech person either so lol). Anyways, it's easier and probably cheaper for Razer to just send you a new pair of headphones then for them to try and figure out their software issues. Like I said they tried to blame it on my computer or really anything else, then just settled on sending me a new pair and guess what they still had the same issues even brand new! I love the Razer Kraken Kitty Editions, they're my favorite headphones yet. Besides the frequent disconnects obviously...they're extremely comfortable, sound great and look great. Sucks we might have to get different products if this software issue never gets resolved. Like I said before it's not just you and I with these issues, I swear everyone who has these headphones has the same exact issues.
     
  11. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    Last edited: May 21, 2021
  12. thakyZ

    thakyZ New Member

    Interesting because mine were kitty krakens and I sent them in as well and they worked for a while and then ended up not working after a while just like yours.

    I have not been connecting mine to a hub at all, only ports that happen to go into the USB3.1 Gen 2 header slot for the front of my computer on my motherboard, also tried the USB3.1 Gen 2 on the back and the USB 2.0 on the back of my computer and they also had the same issue. I have tried a pair of 3.5mm jack headphones and they have absolutely no issue, then again they aren't USB or used alongside Razer Synapse
     
  13. foxyfate

    foxyfate New Member

    Mine are also not on a hub, they are connected directly to the back of my computer where the motherboard is. It's a Razer Synapse issue. I've tried working with the support team and they just sent me another pair of headphones instead of fixing the software and the brand new headphones they sent me still disconnect and reconnect. I've had my computer looked at (it's fine) and tried on a different computer with Razer Synapse and same issues. But when I run my peripherals without synapse there aren't any disconnect issues.
     
  14. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    As a Vanguard of the RAZER Insider, I am not to discriminate other Insiders opinions or their facts of why things do not work. Hear me out~~~

    Synapse only work well, as long as the PC and its OS and the internal hardware are performing at good state. Factors to check that your PC is performing good~~~
    • Is it running Windows 10?
    • Is the Windows fully up to date
    • Confirming all your internal hardware are at the state of working order (test out by installing HWINFO)
    • Drivers on your pc are in working order
    • Is Synapse fully updated
    • Have you uploaded latest firmware onto the RAZER peripherals
    • Does your PC have too many applications running in the background (except for Microsoft and *.dll services)
    • Does task manager display idle state CPU or fluctuating clock (virus attack)
    If it is an issue with with the Synapse, there will be hundreds and thousands of other Insiders and RAZER peripheral users that will be having the same issue. RAZER Synapse development team have contributed their efforts to getting the RAZER peripherals to a state of working order.

    There will be times when things do disconnect randomly, due to data flow (bandwidth) issue within the hardware or low power driven.

    I've seen times when my task manager detect number of programs running in the background, and these did cause my peripherals to act funny also.

    To perform full extensive level of OCing, you have to turn off / disable every unnecessary programs and deliver enough cooling.

    Also viruses cause peripherals to dysfunction.

    Another way to find out if it is RAZER side that is having an issue, try plug your RAZER peripherals and install Synapse to another good working Windows 10 and see if it is just as same or better.

    By experimenting variety of checks, it helps you to develop your troubleshooting skills, which can be a great skill set to have; and analyse what works and what does not.
     
    Last edited: May 21, 2021
    -Mr.Nobody- likes this.
  15. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    Because Synapse software works among Windows; the Windows update from Microsoft can have some issues or conflict of making the Synapse to perform normally.

    Microsoft releases new Windows updates every fortnight Tuesdays. RAZER Synapse development teams job is to maintain the Synapse, that it works well with the new updates, or implement a new update onto Synapse.
     
  16. dezi1476

    dezi1476 New Member

    i have the same problem since about 1-2 months my kraken randomly disconnects and reconnects ive tried every possible way also mentioned in this thread razer needs to do something about this im going mad at this time
     
  17. foxyfate

    foxyfate New Member

    I have also done all of the things you've listed as well and have brought my computer in to a professional and their opinion was also that it would be a software issue, the coding isn't good. I feel like it's only with certain Razer products as I have looked through almost all of the threads that have the same issues. I'm not trying to argue but there are lots of other people with these issues! There are lots of other threads of the same things happening and people are getting frustrated. For me personally my headphones are working fine today...they haven't disconnected yet. But it could be completely different tomorrow or it could be completely different an hour from now and I haven't done anything different. That's what makes me think it's a software issue, I could be playing the same game with nothing but discord open and it could be fine or just randomly disconnect. I would love to see this issue resolved because I love my Razer Products...I just wish I could use the full extent of them without any issues.
     
  18. I have the problem with my Kitty Headset since I had it in December 2019. Randomly disconnecting if I keep it connected at all time. But if it's unpluged every morning when I boot my computer and then plugged when the loading is over, I'm free of disconnect for the day. When I forget, the headset quickly remind me to do it. It can't be hardware or my ritual wouldn't change anything. I still check from months to months if someone found something about it, nothing worked so far.
     
    foxyfate likes this.
  19. dezi1476

    dezi1476 New Member

    at this point i probably gonna buy a new headset this time definitely not razer anymore
     
  20. foxyfate

    foxyfate New Member

    Yeah my headset went a few days with no disconnect issues and now it's acting up again after this last Razer Synapse update.
     
    bdapkus likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >