Disconnecting and reconnecting?

Discussion in 'General Discussion' started by TheShykid_, May 15, 2021.


  1. I had the same issue with my Razer Blackwidow Elite. Fix as follows (Win 10)
    Navigate to Synapse 3 app launcher (start menu > synapse app icon > right click open file location)
    Right click > properties
    Compatibility tab > run compatibility trouble-shooter
    Run programme in compatibility mode for windows 8

    This has fixed all my disconnecting issues. Keyboard / software is now working perfectly.
     
    MareGM and FiszPL like this.
  2. Dalia.

    Dalia. New Member

    This is insane, I have exactly the same problem.

    I am huge Razer fan, I have the black widow keyboard, viper mini mouse, quarts base stand, goliath mouse pad, quartz siren mic and even the chair to go with it all...

    I have been struggling with my headset disconnecting the whole time for the last two weeks!

    I am so frustrated. I have literally tried everything.

    I've even formatted my laptop to see it that would work, but alas NOTHING works!

    If someone finds a solution please let me know
     

  3. Read my post directly above & run synapse 3 in windows 8 compatibility mode.
    Let me know if it works please.
     
  4. kaaats

    kaaats New Member

    I have the same issue: my headphones kept disconnecting and reconnecting, got them replaced, now they are fine, but now my mouse is doing the same thing to the point that it is not usable. It has to be a software issue! It happens when Synapse is running. After closing Synapse app, the issue disappears.
     
  5. Run synapse 3 in windows 8 compatibility mode. See my earlier post. Steve
     
  6. Xeillious

    Xeillious New Member

    I tried this and so far and my mouse still is disconnecting.
     
  7. Xeillious

    Xeillious New Member

    I judged too soon, but after a couple of days without using the mouse, it seems to be working fine. The computer probably would need a restart before you'd see if it works or not.

    (edit) I'm not going to continue making posts going back and fourth but the bottom line is that it stops for about a couple of hours and then continues on like it was never fixed. Sorry about the confusion.
     
    Last edited: Sep 6, 2021
  8. Sr.Jm.

    Sr.Jm. New Member

    I got my headset like 3 months ago and everything was fine (Razer blackshark pro) then after some synapse's updates my headset started disconnecting once in a while. But oh my god since the last update they disconnect like 10 times in a row every 5 minutes.

    I had headphones from razer before these and the previous synapse was also terrible but this is BEYOND terrible.
    If im paying 200€ for a headset I expected them to work perfectly as long as I took good care of them T-T

    As I have seen in this thread there is no fix for this, im just going to hope the next synapse update makes it a bit better... :slightly_sad:
     
  9. kit_thebxtch

    kit_thebxtch New Member

    I've been having this issue for months. MONTHS. And just on my latest headset, I had this same issue with the Kraken Kitty before this one... so double the time, I guess. A year? Way too much time considering the price tag on Razer products.

    Anyways, I've tried the above solutions, been fiddling with various tests of trial and error. Here's what I've learned:
    • It is definitely a Synapse problem. Usually every time it updates, it breaks for weeks. My theory is that there is spaghetti code somewhere that borks on the backend.

    • When swapping from audio to audio and voice input, the headset is more likely to freak out than not. The headset also really hates lower volumes having a steady connection, and if you have a haptic setting? ggwp

    • I can set my watch to it rapidly flickering its connection starting at the same time every night. My theory is this coordinates with Synapse uploading your profile setting backups to their cloud (potentially shorting the wires with the voltage surge, then causing an infinite loop?), and may be tied to it pinging the latest cloud settings whenever the mic is accessed by a program.

    Now. How I got it to be bearable:
    • Yelled at my PC a lot. It made me feel better. Also got my money back for the USB docks I bought and instead invested in Amazon's vast selection of cord lengths.

    • Utilized Windows Firewall and my antivirus to block all Razer processes from accessing the internet. There's no internal way in the program to disable the cloud connection and sync. Make sure you are logged into your Razer account in the program prior to disabling internet access.

    • Disabled any of the extra modules I wasn't using. Chroma Studio is really all you need unless you have the specific devices/connections the other modules utilize. Chroma Studio, on its own, can handle your RGB and coordinating it across your devices. (Uninstalling the modules is a pain in the rear-end. Be prepared for flickering connections and Synapse to freeze up repeatedly.)

    • For funsies, ran the repair tool from the uninstall interface, used a program to wipe up any dust in the registry.

    Other fun activities I really shouldn't have to do to get the quality I want from this headset for the price I paid:
    • Disabled Realtek's devices from the device manager. For some reason, Realtek and Razer like to conflict.

    • Installed my RGB programs (I use an ASUS standalone for my GPU) on separate drives.

    • Regularly use the Bluetooth re-pairing tool to refresh my headset connection. Also, regularly update my Bluetooth driver.

    • Keep my headset charged. I do think there is some merit in some of the disconnections being tied to voltage in some way, because the flickering happens frequently when the power is low but not low enough to trigger the low battery warning, especially if my volume is low. (These disconnects are frequent and occasionally disable the mic until I reboot them. However, they are not as rapid as my nightly "settings syncing to the cloud" epilepsy attack issues are.)

    TL;DR, Razer: Fix your internal wiring for the voltage, and fix your program (or give us some options to disable the constant sync plz&ty).
     
  10. its gotten significantly worse for me as well in the last 4 days after a synapse update. it's disconnecting and reconnecting constantly, in quick succession, to the point it could not be used. I tried everything above with no luck. fortunately it's the only razer device i have and it's working with synapse installed. However now I can't control anything on it without synapse which defeats the purpose of chroma headphones.
     
  11. FloralWizard02

    FloralWizard02 New Member

    Same thing is happening to me
     
  12. Sr.Jm.

    Sr.Jm. New Member

    It has gotten to the point where I can't use the headset at night (the time when it gets worse) because of the constant connecting and disconnecting, and 2 beeps every time that happens is the perfect receipe to drive you nuts. I honestly don't know what to do anymore like i was fine when this happened 3 times in one day, but at this point it happens more than it doesn't.

    I'm hoping they can fix this by the next Synapse update. I was also thinking about sending something to razer support but from what I've seen they don't really care.
     
  13. memohgogo

    memohgogo New Member

    This whole situation is such BS. I got my headset in April and it worked completely fine until a week or so ago. Now I'm going through the same problems everyone else is in the thread. If I manage not to move the headset's cable it doesn't disconnect AS often, but it still disconnects. And I know this is a software issue because every time my kraken kitty disconnects my keyboard, an ornata chroma that i've had for 4+ years with no problems disconnects and reconnects at the same time with the headset.
     
  14. Hikkeyy

    Hikkeyy New Member

    Past Week maybe it's been brutal, including the time i'm writing this
     

  15. It is a pity really, both me and my wife have bought the Razor Kraken and the Razor Kraken Kitty headsets, first my wife started to complain about her headphones disconnecting and making a popping sound, she had them for almost a year. So we switched out, because my headset wasn't having the issue, me wearing her Kraken Kitty and she wearing my Razor Kraken headset. So initially I didn't experience it until push came to shove being in a video conference call, then it started acting out, I had to switch back to my laptop's speakers because I could literally not follow the conversation, due to the constant disconnecting and reconnecting. I doubt that it is a windows setting causing this, since we tried it on several different laptops.

    We've since returned the Headphones to the shop where we bought it, hopefully sending in the unit back to the supplier, might resolve the issue. However since waiting for any feedback from the supplier, my Kraken Headphones has also started to intermittently disconnecting. I am starting to wonder if I should rather spend my hard earned money elsewhere - I'm not willing to spend such a high amount of money on a product that spazzes out within a year.

    I thought this might be an isolated incident, but since I found this thread, I thought sharing my experience might help someone when choosing a headset provider.

    I also doubt that I will receive any form of feedback from Razor on this post, just as all the wonderful feedback the other users who had feedback from Razor. I mean who cares about customer feedback right?

    Kind regards
    The guy who seriously considers that the only Razor you should buy is the one you shave with.
     
  16. needurblood

    needurblood New Member

    Hey guys! I was with the same problem and what worked out for me was changing the headset from USB 3.0 port to a 2.0 one, then I changed Synapse 3 compatibility to windows 8 on its properties and also disabled the marked option on energy management of the usb devices listed on device manager! *sometimes it still happens but not as much as it was happening before*.

    *sorry for my english, this is not my 1st language :c*
     
  17. Manchiis

    Manchiis New Member

    I also have the same problem. I got my Razer Kraken Kitty 1 year ago and it was completely fine. This year, the issue appeared. When I increase the volume they do the popping sound and disconnect. Even though, Razer Synapse is turned off. Now, I think that I'm gonna uninstall it and see if they will disconnect or not.

    Also, I tested them on the other PC, on which Razer Synapse wasn't installed, and they were doing the same thing. Disconnecting all the time when I wanted to increase the volume.

    I'm really disappointed in Razer. I thought that the headphones will work for a lot of time without any issues T_T
    Even though, my Mamba Wireless mouse works perfectly.
     
    Last edited: Oct 11, 2021
  18. EcrubizGARNET947

    EcrubizGARNET947 New Member

    Hi. I have facing disconnecting and reconnecting internet problems. Maybe its required high internet connection for headset
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >