Does anyones Cores USB ports actually work?

Discussion in 'Systems' started by Katana, Feb 17, 2017.

Thread Status:
Not open for further replies.
  1. AssembIer

    AssembIer Active Member

    Yet again... someone is pairing the Core with the Blade for comparison, which is utterly ridiculous. The Core was primarily made for the Stealth and that does not suffer from this issue (but the CPU ist still a bottleneck). The USB issues are also not related to that, otherwise the Stealth would't be affected.

    Why would anyone buy a Core for the Blade, when even a GTX 1080 sometimes can't produce more fps than the dedicated 1060 in the Blade ? And for the future like Katana said: GPUs will be faster but the available bandwidth stays the same. That makes it even more difficult to get the performance out of the external GPU.

    People should see the Core as it is, a solution to provide GPU power to notebooks that are otherwise relying on integrated graphics.
     
    surfer1081 likes this.
  2. Katana_x_II7

    Katana_x_II7 Well-Known Member

    Because I want to go home and plug in my 1060 blade to my 4k screen and play games in 4k....which the 1060 cant do. But I still want decent graphics on the go so I dont want a stealth since thats just for working and very light gaming.
     
    surfer1081 and TrueEddie like this.
  3. bizupSmitten777

    bizupSmitten777 New Member

    I'm not 100% sure how the bandwidth on graphics card works, but I know that I have USB problems at any point on my system, even without launching any apps and simply opening the start menu of Windows 10. I would assume there's not much bandwidth being used at that point (if that's how GPU BW works?)

    I haven't even run games on my Stealth as I use it for work. I can't imagine the frustration I would have if I were actually trying to game on this "gaming" machine with the USB disconnects I've been getting.

    Given how Razer has handled this known issue, I would have to assume that those of us having these problems are screwed.

    We were piloting this device in my department as a solution for professors that wanted GPU processing for certain tasks and mobile "power users" with multiple high res monitors. Razer has made it an easy decision on how to proceed. I should have stuck with a top tier vendor.
     
  4. Cyraxus

    Cyraxus Active Member

    Actually many people plug in the Core to a Blade like myself. We don't all have the Blade with a 1060 running Pascal. Some of us have the Blade with a 970m. There is a huge performance difference obviously when you use a Core with a 1070 installed compared to the integrated 970m in the blade. The blade also does not heat up at all when you use it with the Core. The USB issues with the Core is definitely an annoyance that Razer should have seen coming. I've had this issue since the beginning and it's frustrating.


     
  5. bizPinkJASPER298

    bizPinkJASPER298 New Member

    So I have my own theory to throw into the mix. Based on what I've seen from people reporting USB devices freezing randomly (both here and on other forums), it seems like the problem might be with the Thunderbolt 3 drivers of the Razer laptops and not with the Core itself.

    I have the 2017 Blade and the Dell TB16 dock, and have the USB mouse/keyboard freezing issue. My friend has the late 2016 Blade, and when I plug my dock into his laptop it works just fine. I looked at the Thunderbolt driver and firmware versions on both the laptops, and his older Razer Blade has newer thunderbolt firmware. So it looks like, for whatever reason, Razer used an older firmware version on their new laptops which might be causing problems with docking stations you plug into the thunderbolt port.

    To test this out, could people who have a Razer laptop with a dock like the Core or Dell TB16 fill out a google form I set up? If the problem is with the thunderbolt firmware, at least there is hope of a software fix being released.

    Here's the link to the Google form

    For the questions asking about driver/firmware versions you can find them by doing these steps:
    1. Right click on the Thunderbolt Software icon in your system tray (by the clock)
    2. Go to Settings
    3. Click on Details (bottom left)

    Thanks!
     
  6. Cyraxus

    Cyraxus Active Member

    I noticed that too after I reformatted my Razer. The Thunderbolt drivers are older. I'm just afraid to install newer drivers/firmware that isn't sanctioned by Razer.

     
  7. AssembIer

    AssembIer Active Member

    I just filled out your form, maybe you should add a field for adding the GPU that is installed after selecting the Razer Core.
     
  8. bizPinkJASPER298

    bizPinkJASPER298 New Member

    Good idea, added.
     
  9. retroMaizetech516

    retroMaizetech516 New Member

    @R0cketMan

    Just filled in your form. I am using a 2017 Blade 14 with a Dell TB16 dock ... I too am experiencing freezing issues with USB mouse and keyboard (Naga 2014 and Anansi). However, I have noticed that the issues disappear when the Blade is running from battery rather than plugged into the mains. Has anyone else noticed this?
     
  10. bizPinkJASPER298

    bizPinkJASPER298 New Member

    Great catch, I just tested it out and I get the same result: no more stuttering/freezing when on battery power. I have the same setup as you for laptop model and dock. I wonder if the same thing happens for those using the Razer Core too.
     
  11. bizupSmitten777

    bizupSmitten777 New Member

    I just filled out your form. I'd be interested to see if you find that there is a firmware version that does not have this issue.

    Unfortunately I feel like the evidence that this is a design issue is pretty strong and I don't know that it can be fixed with software....
     
  12. retroMaizetech516

    retroMaizetech516 New Member

    So with a very heavy heart I returned my Blade (luckily I had bought it through Amazon so easy to return for refund). This issue coupled with the noisy fans felt like too much compromise for such an expensive piece of kit. New desktop and ultrabook incoming.
     
  13. junglex

    junglex New Member

    I wish I found this thread before I purchased my stealth and core combo. My core is currently in for its first RMA (I've used it once ...) and the support team is offering a refund for the core as this is now a known issue with out a workable solution. This puts me in a bind as with out the core, I would not have purchased the stealth, especially the 4k version.
     
  14. Cyraxus

    Cyraxus Active Member

    They said there is no "workable solution"? Wow. What was wrong with your Core? Just the USB issue?
     
  15. junglex

    junglex New Member

    The issue is only with the USB inputs into the core. I am using a lancehead mouse and a blackwidow TE keyboard. I do not have any issues when the components are connected directly to the RBS, however, experience unusable freezing/disconnecting when I plug either the keyboard OR the mouse into the core. I have tried two different lancehead mice (purchased one for my brother) with the same results. I really want to love all of these products as this lot was my first set of Razer purchases but am very disappointed. Had I known about the USB issues, I would have looked into non USB solutions for keyboards and mice. Additionally, while I appreciate the offer to return the core as it does not work as expected, if i do so, I am left with an ultrabook with an integrated graphics card. I likely would not have purchased a model with a 4k display or a RBS at all.
     
  16. jza80a

    jza80a New Member

    Utter nonsense. My i7500U Stealth has had this issue from the moment I connected it to my Core. Periodic mouse freezes, intermittent disconnects of keyboard, you name it.

    @R0cketMan, added my details to the form. Thanks for setting that up.
     
  17. AssembIer

    AssembIer Active Member

    Read post #78 and then mine again, we were not talking about the USB issues .....
     
  18. statton4

    statton4 Member

    have you tried changing your power settings ? my stealth/core stopped the random disconnects and freezes after i changed the sleep/screen off etc to never____. i have had my system for a year now, no issues. just upgraded the ssd from 128Gb to 500Gb. just my 2cents.
     
  19. Wengesystemgreat566

    Wengesystemgreat566 New Member

    new core owner here, just got it yesterday.
    I have read all through this post and some others and none of the various workarounds have helped me, I have constantly disconnecting USB devices.

    I do, however, have some information to add:
    My keyboard has the most disconnects, followed by my mouse. My wireless headset adapter plugged into the core never has an issue and audio is always good, even when mouse and keyboard are being funky.

    Stranger yet, my keyboard has 2 USB 2.0 ports on it, and I can plug my mouse and a logitech controller into the keyboard while the keyboard is plugged into the core, and even when the keyboard is disconnecting the mouse and controller might still be working, they all disconnect seemingly independently, even when daisy chained.

    I however have found additional information that supports the firmware theory @R0cketMan posited:
    https://egpu.io/forums/implementati...e-with-the-razer-blade-stealth-and-devil-box/

    ^That's the only egpu.io case someone has done with the Powercolor eGPU - and the reviewer confidantduck quickly brushes over something very important: USB disconnect issues!

    Meanwhile there doesn't seem to be widespread complaints about disconnect issues with the DevilBox (though, admittedly that could be due to lower adoption compared to the core)!

    This seems to pin the USB problem on Razer and potentially on the Stealth, so perhaps some sort of way to update the firmware or a driver fix for the razer could solve this problem.

    I have, however, no idea if there is firmware or a driver already available we could use, or if we'll still need to wait for Razer to acknowledge, debug, and fix the issue.

    EDIT: forgot to mention I have the new RBS with 13" screen
     
    Last edited: Jul 26, 2017
    Katana likes this.
  20. Cyraxus

    Cyraxus Active Member

    I'm pretty sure people with the Core (like me) are just going to be screwed. There is definitely an issue and if they haven't addressed it by now they probably won't. They'll just come out with a newer version that we'll have to buy.

     
    statton4 likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >