Does anyones Cores USB ports actually work?

Discussion in 'Systems' started by Katana, Feb 17, 2017.

Thread Status:
Not open for further replies.
  1. statton4

    statton4 Member

    i think u may b right.....
    That is part of the reason for me deciding to build a pc.
     
    Cyraxus likes this.
  2. Wengesystemgreat566

    Wengesystemgreat566 New Member

    You're probably right - but my theory is that it's not a new core you'll need but a new Blade or RBS, as the USB connectivity issues occur with a RBS even on a Devil Box. Then there's the dim hope it can be a firmware or driver fix, but a year later that seems like wishful thinking.
     
    Cyraxus likes this.
  3. surfer1081

    surfer1081 Well-Known Member

    All the power is gravitating from the stealth motherboard, as its shared between all usb ports and the core. So this is where the shortage and even CPU bottleneck occurs. From what I've gathered.
     
  4. The weird thing about it is that the USB Ports on my Core work perfectly when I plug it up to my X99 systems. I currently own a 2017 Blade but I've also owned a 2016 Blade Stealth and the USB ports didn't work correctly with either of my Razer laptops.
     
  5. eJonny

    eJonny New Member

    Hi everyone,
    Let me add my experience because I think it might be a little different.

    I'm using an HP Spectre X360 laptop.

    I have the following USB peripherals:
    * Blackwidow Keyboard
    * Orbweaver Keypad
    * Mamba Mouse
    * Firefly Mouse pad
    * Stargazer Camera
    * HTC Vive

    I have also purchased a Anker 7-port powered USB 3.0 hub with 36W.

    I'm using an Asus GTX 1070 in the core.

    I connect a gig Ethernet connection into the Core.

    When I connect the keyboard, keypad, mouse, and mousepad into the core, I get the disconnects everyone has mentioned. I cursor will pause for about 10 out of every 60 seconds, despite continued moving of the mouse. The keyboard and keypad will flash their LED off and then back on, and keyboard input stops, the same key repeats about 20 times despite a single press, and input to the keyboards stops.

    I have tried disconnecting all devices except one and get the same problem.

    I connected the HTC Vive as the only device on the Core, and the base stations are initially detected and then dropped with a "Unknown USB Device (Port Reset Failed)" in device manager.

    I tried connecting devices to the hub (to provide more power) and then to the core. I experienced the same problem.

    If I connect the USB devices to the hub and then directly to the Spectre, there are no issues.

    So, this doesn't seem to be a USB power issue. This doesn't seem to be an issue with RBS firmware (I have the latest TB3 firmware) and I'm not using a Razer Blade. The appears to be a problem associated with the hardware on the Core itself.

    I started an RMA today. We'll see if Razer can fix. I hope I can get a refund if they can't.
     
  6. pir0zhki

    pir0zhki New Member

    Nah, sounds like the standard description of the issue to me.

    Current speculation as far as I can tell is that the RBS does not run the latest firmware version for its thunderbolt hardware, based on comparing the old Stealth firmware version with the new one. I'm pretty sure the two RBS models use different controllers though. The new one uses the JHL6340, but the JHL6340 was only released in Q2'16. Thus, the old stealth would likely have the older controller, the DSL6340.

    With the driver provided by razer (or perhaps the factory state, idunno), the firmware installed seems to be NVM rev.9 -- but from the digging i've done so far, the latest TB3 17.1.64.250 software (not available from razer; you have to dig to find it) appears to support the JHL6340 running NVM rev.19. Unless this is a typo, it tells me that we are actually running on an older version of the firmware, and a newer version has not yet been provided by razer.

    Of course, this could all be a red herring, as it might not have anything to do with the firmware revision in the first place.

    [​IMG]
    I can at least confirm that installing the newer Thunderbolt 3 software doesn't fix the problem. So far I've been unable to locate any downloads specifically for JHL6340 firmware, and I don't know that I'd trust them either way (on the off-chance that an alternate vendor made some kind of modifications, or on the chance that razer themselves require such modifications for the Stealth).
     
    Last edited by a moderator: Jan 3, 2018
  7. eJonny

    eJonny New Member

    I think that's why my situation is a little different. I'm not using an RBS and have the same USB problems that have been reported here.

    I've had my Core sent back to Quanta (the contract manufacturer for the Core) on RMA.

    Even though I explained that the problem is with the core and doesn't occur when I connect the Razer USB peripherals to a hub and then directly to the HP Spectre laptop, the Quanta explanation is that there must be a problem with my laptop.

    I have escalated the case with Razer and will let everyone know what I hear. At this point, I'm asking for a refund for a defective product that can't be repaired.

    I wish someone from Razer took an interest in this thread and provided feedback.

    Well, here is the disappointing and sad update:

    On August 9th, I escalated the issue with Razer and requested a refund as Quanta did nothing to resolve the issue with the USB problems on the Razer core.

    On August 11th, I was given an RMA and a shipping label for the return.

    On August 12th, I shipped to Core back to Razer (this time to Irvine and not Quanta in Fremont).

    On August 15th, the product was delivered to Razer.

    On August 22nd, I received an email saying that I would be credited in 5-7 business days.

    On August 30th, I contacted Razer Order support live chat and was told that it had only been 6 business days and not to worry, and to trust Razer that I would have my credit "tomorrow".

    On September 1st, I contacted Razer Order support live chat and was told that the refund process had been initiated but needed to be verified by finance. I explained everything politely, and asked to speak to a supervisor. I was told that the last supervisor I had spoken with was on leave and that no other supervisor would be available for 5 hours.

    Why does it take this long to get a refund? Who else can I speak with at Razer to finally get my refund?
     
    Last edited by a moderator: Jan 3, 2018
    vistar likes this.
  8. Wengesystemgreat566

    Wengesystemgreat566 New Member

    I have a very interesting update for people still having issues here:

    The problem is almost certainly software/driver based, not firmware or hardware.

    I have begun dual-booting windows/fedora-linux and I have gotten the Core to work properly in linux with the proprietary Nvidia driver for my GTX 1070.

    I haven't yet set up pseudo-optimus for hot plugging, but I can absolutely use hardware acceleration, and have had gaming sessions of rocket league running through my GPU on an external display connected to that GPU.

    I moved all my USB devices back to the core (instead of a hub I had purchased due to the disconnect issues). In linux I have never once experienced a USB disconnect. I even tried to simulate bandwidth issues on the thunderbolt cable by copying files to my backup disk (connected to the core) and gaming on the GPU at the same time, while all my peripherals were also connected to the core. For comparison, in Windows I experience disconnect issues before I can even finish typing my password at the login screen.

    This to me strongly suggests the issues are either related to Windows' USB/thunderbolt drivers, or Razer drivers we install on the system.

    I wouldn't recommend going down the potentially fruitless avenue of RMAing your core as it's likely not a hardware issue. If you do suspect you have a hardware issue I recommend you do as I have and test the core in linux.

    Hopefully someone else finds this info useful and maybe gets a few ideas, unfortunately I have no ideas how to fix this on Windows other than to wait-and-see.
     
  9. taubkin

    taubkin New Member

    Hopefully someone from Razer.

    But thanks for experimenting and bringing this back.This is both promising and infuriating.

    Makes one wonder about Mac OS uses for the core as well.
     
  10. Joikansai

    Joikansai Well-Known Member VANGUARD

    I almost bought Core V1 from Mac user, and he said that the port has no issues as other reported, he was using it with GTX1080TI. Well I didn’t buy it so not sure if he doesn’t lie.
     
  11. hbearnbd121

    hbearnbd121 New Member

    Thank you for the info wengesystemgreat556. That is very informative. Will wait patiently for a fix for Windows. Wondering if the core v2 will have that issue as well?
     
  12. moho1

    moho1 New Member

    This is great news! Although, I'm afraid I'm not holding out much hope that we'll see an official fix...

    In other news, I replaced the Killer 1535 WiFi card in my RBS with an Intel 8265 and (anecdotally) things are now much, much worse. Upon docking the RBS to the Core, the two seemingly negotiate forever, with the Core frequently dropping out, occasionally needing a re-plug, or the RBS blue-screening with a thread exception (which I haven't bothered investigating, but probably should). Other than the physical replacement of the WiFi card, there was some mucking about with the Killer and Intel drivers, so I have my suspicions, but it really is pretty anecdotal.
     
  13. sd2602

    sd2602 New Member

    So now that the V2 is out and there is no official fix for the v1, if I rma my v1 is it possible it will be replaced by a v2? Razer has to know about this issue and will maybe just quietly replace the v1s with v2s as they are sent in? Just a thought.
     
  14. Katana_x_II7

    Katana_x_II7 Well-Known Member

    I doubt they would do that. They probably have a huge amount of refurb v1's since so many people have sent theirs in. And the v2 is still brand new so probably dont have enough of them for people who actually want to buy them like usually happens when they come out with new products. If that does happen to anyone though, let us know!
     
    Last edited: Dec 18, 2017
    vistar likes this.
  15. sd2602

    sd2602 New Member

    Well just got
    After having an interesting chat with support I learned two things. First, they are admitting the v1 has the usb issues and their fix is to send a usb hub to remedy the problem. Unfortunately that sounds like to me there will be no effort into actually fixing the actual problem. So then I asked if I could just send my v1 back and get a v2 in return. The answer surprisingly was yes but in a round about kind of way. I had to give my order number and would be refunded for it and then could use the credit to just buy a v2. The only problem here is I bought my core second hand and now can’t get the order number from him. So if I had the order number I would have a new v2. I think at this point I’m just going to sell my core and get an Aorus unit.
     
  16. Joikansai

    Joikansai Well-Known Member VANGUARD

    Do you mean Aorus Gaming Box? You’ll facing same USB ports issue, look first at eGPU subreddit or eGPU io before make a decision, with MacBook or gigabytes laptops it seems good but if you have Blade Laptop you’ll face disconnecting issues, i think dell laptops also has issue with it (1070 one), and Linus recently reviewed 1080 one with stealth, I think he found also the USB port issue but he didn’t focus on it.
     
  17. Katana_x_II7

    Katana_x_II7 Well-Known Member

    oh really? so i could contact support and return my v1 and get my money back and get a v2?
     
  18. Cyraxus

    Cyraxus Active Member

    I would definitely do that Katana. i called support within the last two weeks because of my Core v1 and they indeed did some troubleshooting and then sent me credit to use on v2.
     
    sd2602 likes this.
  19. Katana_x_II7

    Katana_x_II7 Well-Known Member

    Awesome! thanks for the tip!
     
  20. sd2602

    sd2602 New Member

    Yep! I’m out of luck since I don’t have an order number but they are doing what they can.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >