Firefly V2 Mousepad Won't Connect to Razer Synapse 3?

Discussion in 'Mice and Surfaces' started by EPICBRO75, Feb 22, 2021.

Tags:
  1. EPICBRO75

    EPICBRO75 New Member

    Recently. I got the new Firefly V2 for my birthday, and I was so excited! When I plugged it into my computer, which has multiple other razer products installed onto the synapse software, It didn't show up. I have tried, multiple USB ports, reinstalling the synapse software, and restarting my PC multiple times, but nothing seems to be working! If I could get some help, that would be greatly appreciated! Thanks!
     
    pancholr likes this.
  2. FiszPL

    FiszPL Well-Known Member VANGUARD

    I'd try with "clean install" - go to windows device manager, find you Firefly V2 mousepad, and remove it (if you have option to remove with drivers - check that box). Uninstall Synapse software.
    Download CCleaner and cleanup your PC (and IMPORTANT - also registry). Do a reboot, and after it - install Synapse 3 again.
     
  3. EPICBRO75

    EPICBRO75 New Member

    Thank you so much! It worked!
     
    FiszPL likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >