First Razer Blade 15 - Screen Chassis issue?

Discussion in 'Systems' started by ri0ku19, Jul 17, 2019.

  1. ri0ku19

    ri0ku19 New Member

    Hello everyone,

    Finally after years of wanting one, I finally got my first ever Razer Blade 15 (Base) thanks to Prime Day and a great deal.

    I received the item today and immediately noticed a couple of things.

    First, the top left rubber around the screen has a part that is thinner than all the rest (as if it was stretched out and snapped a little) and you can see a shiny silver metal behind it.

    Second, when the lid is closed, there’s a slight bend in it (upwards) which means you can see a gap between the lid and the base of the laptop. I can press down on this and you can see it flex.

    The problem is, I’m not sure if replacing it will make any difference? (Also there are none left at Amazon, so I can only ask for a refund at the moment unless they come back in stock in 30 days) I don’t really want to return it for a refund as il lose out on the great deal price.

    Not even sure if this is just a normal thing?

    [​IMG]
    http://i64.tinypic.com/28aqc2h.jpg



    (Sorry, couldn't get the attachments to show, so linked instead)
     

    Attached Files:

    Last edited: Jul 17, 2019
  2. Hey mine is the same on Blade15 advanced, but the front is good, and it closes nice, i think its no big deal
     
  3. Joikansai

    Joikansai Well-Known Member VANGUARD

    A bit gap between lid and keyboard is for avoiding the keys making touch to the screen, on long term usage it may remain a press mark on screen if it tightly closed, beside there’s intake from keyboard since some users use as well on clamshell condition. So I believe it’s designed so, I’ve also a bit gap on my 2018 advanced Blade 15.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >