FIXED :: Blade 17 - external monitor via USB-C/Thunderbolt 4 not working

Discussion in 'Systems' started by Ribsletics, Jul 6, 2022.

  1. uncleropeadope

    uncleropeadope New Member

    update - i'm an idiot, didn't see page two of this thread, rolled back the nvidia driver, everything works except the dead wireless mouse dongle, guess I'm going mouse shopping again...
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Update:

    We have found that by updating to the latest NVIDIA driver (later than 512.33), the USB-C port will not work when connecting to an external monitor. Please check the following:

    • The Blade 17 2022 | RZ09-0423x (both USB-C ports will not work).
    • The Blade 15 2022 | RZ09-0421x (the USB C on the right side will not work).
    • For QHD 240Hz SKU, which supports Advance Optimus (the "Manage Display Mode" option in the NVIDIA control panel will not be present).

    Razer is aware of this behavior, and the Support Team is tackling this issue and currently communicating with our developers. Our workaround is to perform a display driver rollback to 512.33, the same version in the Windows update. If the rollback button is grey out, uninstall the current driver and perform a Windows update check.
     
  3. DorGor

    DorGor New Member

    Did you see the post on page 2 of this thread? One user said they updated their bios and monitors work again with latest drivers. Anyone know if the BIOS update solution works with the Blade 15?
     
  4. DorGor

    DorGor New Member

    Oh also for the Blade 15 2022, for me the left side USB port works but only for 1 monitor. After I rolled back drivers I can get everything working again.
     
  5. Mack_

    Mack_ New Member

    I have Blade 15 advanced model RZ09-0367, but nothing worked for me.
    I tried nvidia drivers 512.15 and 512.95 no success.
    Updated with Firmware Updater to v.14.1.53.1649, but still one monitor connected to thunderbolt 4 dock doesn't work.
    If I turn off working monitor the other one still doesn't show the picture; still no signal. If I switch monitors USB-C cable still nothing changed.

    What am I missing?
     
  6. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    I saw everyone's confirmation, and if you are referring to BudgeMagraw's post, that's right, there's a BIOS update for the Razer Blade 17 2022 (1.06) intended to fix different frequencies shown in the OS compared to the CPU spec and improve the CPU's performance. I added my latest post to let everyone know the progress of the investigation. The team is still working with our devs and accepting feedback/reports from our users since this can help Razer come up with a resolution to any reported issues from the community.
     
  7. Mack_

    Mack_ New Member

    Thanks for answer,
    but as I said, I have Blade 15 and I can't find any BIOS update for it.
     
  8. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Can you send me a PM including a photo showing the BIOS main tab so I can check your laptop's serial number and BIOS/EC firmware versions? Let's continue our conversation privately.
     
  9. plakstra

    plakstra New Member

    I don't know how or why but my BIOS version is on 1.07 16/02/2022?
    P.S. I've done a system recovery a few times now, also have gotten an image from the support to flash a
    USB with. That is the recovery that I'm using right now, but I saw that I don't have a razer icc anymore. and where the file should be is an razer icc with no data.
     

    Attached Files:

  10. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Are you still using the laptop's original operating system or you've upgraded it? I suggest contacting our Support Team by initiating a case number through this link or send me a PM including the following:

    a. MSinfo logs.
    b. Screenshot of Windows version.
    c. Photo of the BIOS main tab.

    Save the file via Google Drive or any online drive, then paste the shareable link to your PM. Let's continue our discussion privately and avoid posting any info on this thread for security.
     
  11. Chernobylite

    Chernobylite New Member

    I can confirm it's, and has been happening with my 2022 Blade 15. I can also confirm with 100% certainty it started with the last two driver updates from Nvidia. To me it looks like it's linked at least partially to Nvidia's Advanced Optimus tech. I hope/assume Razer has reached out to Nvidia by now because this issue has been standing for at least several months, and on a $3,500 laptop it's pretty unacceptable.
     
  12. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Your critique is duly noted. Can you send me a PM with the files from the instructions I've posted above so I can start an investigation on your behalf? Thanks for your cooperation.
     
  13. Thinkfactory

    Thinkfactory New Member

    I've got the same problem. My new Razer Blade 15 (2022) is connected to a Thunderbolt 4 Dock with different possibilities to connect Displays (DisplayPort, USB-C/Thunderbolt 4, HDMI). I use the USB-C Port to connect two identical Displays.


    After I had installed the newest Nvidia driver, both displays, connected to the USB-C Ports, do not work. For investigation started to try all different ports to get a signal on my displays, but with no luck.


    Today I found this post. The workaround to downgrade my Nvidia Studio Driver to 512.59 works. A few seconds after I downgraded the driver, both displays working on USB-C, and all other ports.


    This workaround works for me, but it can't be the solution for the problem. I’m working 3D Software and heavy use GPU Rendering therefore I always need the newest Nvidia Studio driver.


    I've installed BIOS Version Razer 1.09, 22.02.2022.
     
  14. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for sharing your feedback. And yes, I agree that the team should not stop here and continue working with our devs to generate a fix for the laptop's concern. Feel free to submit a case to our Support Team or send me a PM should you need additional assistance.
     
  15. Did you solved it? I got the same laptop, even when doing a clean install of the older driver that did not worked
     
  16. Blade 15 3070ti user here. I have tried rolling back and installing the old drivers and no success. My pc thunderbolt 4 port worked. I installed the new drivers and now it does not worked.
     
  17. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Sorry to hear that the workaround didn't help. I recommend submitting a case or sending me a PM so I can communicate to our Support Team on your behalf. Thanks for your cooperation.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >