[FIXED] Stuttering Audio With Razer Ripsaw (rz20-0178) NOT ripsaw HD

Discussion in 'Razer Support' started by Verdigristechnoboard386, Jun 16, 2021.

Thread Status:
Not open for further replies.
  1. I've been troubleshooting this issue for almost 8 hours and am really hoping I can find some help here. My ripsaw had no problems a few weeks ago but when I plugged it in last night, the audio output through OBS had this horrible stuttering/skipping effect.

    I've tried everything from rolling back my OBS to installing Razer's recommended "Cortex Gamecaster" application which didn't even have Gamecaster anywhere on it. I'm out of ideas, and really not keen on the idea of buying a bunch more splitters and passthrough stuff to have my setup the way it worked before.

    I tried with my Switch to see if it was possibly the signal range or something doing it, but it's not. Happens with my Switch at 1280x720 and my PS2 through RetroTINK 2X Pro at 720x480.

    Found my old Logitech Aux to USB adapter (it might have come from a headset? Windows is recognizing it as a headset). I've tried using my HDMI audio extractor and just plain audio passthrough cables hooked into this. Both are producing crackling, and this is before the signal even touches the Ripsaw. Somehow OBS is just reacting poorly to any audio inputs (except my line in)?

    I Theorized that this might be a USB audio issue, despite my microphone (Samson Meteor) being USB and working fine with my PC. It's plugged into the rear, so I figured maybe my front ports are messed up and/or OBS just doesn't like them. Still stutters.

    I tried recording the issue in action, but strangely it doesn't happen on the recording's audio. So it must have something to do with the OBS application outputting to desktop audio, but not to the recording output??? I tried installing XSplit and it's STILL happening, I guess it's something with my computer, I don't know. It works fine on my TV, and worked fine with my computer a few weeks ago and I've changed NOTHING since then.

    As a last ditch effort, I tried rolling back my geforce drivers. No dice. I'm going to try rolling them back another version or two but I'm not hopeful. I am out of ideas at this point, all I can diagnose is that something between the ripsaw and my computer is causing this.

    • It can't be just OBS because it happened with XSplit too, and rolling back OBS didn't fix it

    • It can't be my USB ports because my USB mic works fine and it happens with every USB port, even with the USB AUX adapter

    • It can't be the ripsaw itself because the passthrough works fine on my TV

    • It can't be my graphics card drivers, since rolling those back didn't fix it

    • It can't be my audio drivers, since the line in while extremely noisy doesn't stutter

    • The recording output doesn't have the stutter
    It has to be something specifically happening with the way my computer interfaces USB audio (but not my microphone for some reason). I tried uninstalling the ripsaw so I can reinstall the drivers and see if that will fix it. Unfortunately, Windows can't automatically find the drivers for this thing and they are NOWHERE to be found on Razer's website or anywhere I can find on the internet, so now my device is totally useless. Does anyone happen to have the drivers for the ORIGINAL rz20-0178 Ripsaw?
     
  2. FOUND A FIX! Installing THX Spatial Audio and setting it as my desktop output in OBS completely fixed it. Apparently this was a bug introduced back in August 2020's Win10 update (I was mistaken about using the Ripsaw a few weeks ago, covid will do that to your sense of time)
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >