Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Fl studio 12 will not download

Discussion in 'General Discussion' started by Imakeugoouch, Mar 2, 2016.

Thread Status:
Not open for further replies.
  1. imakeugoouch1

    imakeugoouch1 New Member

    When i sign in with my razer id it says i do not have a blade registered with my account. I registered it yesterday. Is anyone else having this issue? i got the uhd blade stealth from the windows store if that helps. Because it says this it wont let me start the download!
     
  2. TechtonicTech

    TechtonicTech Member

    i think your best bet is going to the makers of fl studio if you cant download it they should be able to help
     
    Imakeugoouch likes this.
  3. Razer|Halcyon_xf_rzr

    Razer|Halcyon_xf_rzr Well-Known Member

    Hello @Imakeugoouch, please reach out to Support as well if you are still not able to register your Razer Blade.
     
  4. palidamor

    palidamor New Member

    This is the response from Matt Feldberg a couple days ago:

    "
    Hi David,

    We've been backchanneling with Razer support and there's seems to be a bug they are working out within Razer Synapse specific to the Blade Stealth serials.

    Hope to get this sorted ASAP or at least manually register your product through our validation system. Hold tight while we await orders if you could!"

    Hopefully it is resolved quickly.
     
  5. Jaboltic

    Jaboltic New Member

    I"m having the same problem...
     
  6. Proto_GT

    Proto_GT New Member

    Same here, just got the UHD Razer Blade Stealth in the mail and have registered it with Synapse. Made a support ticket also, hope this gets resolved :D
     
  7. Ditto...

    This is annoying...I really wanted to try out the software. :)
     
  8. Proto_GT

    Proto_GT New Member

    This still isn't resolved? I have made a support ticket and everything and still nothing.
     
  9. SmellyMcSmelly

    SmellyMcSmelly New Member

    Downloading fl studio still does not work, just got the blade stealth but I cant download it, hopefully it is fixed soon.
     
  10. Sorry, I;m a little clueless. What do you mean by registered with you account? Where do u register it....
     
    TheNavalCrafter likes this.
  11. SmellyMcSmelly

    SmellyMcSmelly New Member

    Well when you get your laptop you go to the razer site and register your laptop, after that you should be able to download fl studio but it says your account does not have a blade registered.
     
  12. TheNavalCrafter

    TheNavalCrafter New Member

    Can you refister other products besides laptop?
     
  13. i am also having this problem. cant get FL studio. I think this is broken. Not sure waht to do about it.
     
  14. For me, it finally worked ...after like 2 months or so.
    Registered my RBS in Razer Synapse..and for a while the FL download wouldn't recognize that I had registered the device. As i wasn't in a rush I just left it alone for a while as I had other things to take care of. Recently when I retried the link, the registration was recognized.
    I believe there were people who got much more immediate responses by reaching out to support (as Razer|Halcyon had recommended above. )
     
  15. ASHKANIMOUS

    ASHKANIMOUS New Member

    i had this issue too customer support was able to knock it out and sent me a link to the download.
     
  16. venturePinkLacespot810

    venturePinkLacespot810 Active Member

    Hey all, I had this exact same problem when I received my Blade. I shot support an email, and they sent an email back to me requesting my Blade's Serial number, the charger's serial number, and the model among other things. I responded with all the correct info, then they sent me a key for FL studio! So just ask support, they were very helpful for me.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >