Fortnite: Battle Royale paid to play not working

Discussion in 'Razer Cortex' started by Akimbowles, Jan 1, 2018.

Thread Status:
Not open for further replies.
  1. NyteNight

    NyteNight New Member

    I am experiencing this as well and it shows the game is featured in the 'Rewards' tab for 3 Zsilver a minute but doesn't show up in the 'Games' section for Fortnite.
     
  2. RazerSapiyo

    RazerSapiyo Community

    Hi Insiders, is this issue made known to the Cortex support team? If you haven't please head to the Cortex app and click on your profile icon on the top right. It will show a drop down menu and then click on "feedback". The Cortex team is pretty responsive and if they're aware, it should get fixed in no time.
     
  3. Eurioin

    Eurioin New Member

    I gave a feedback about it yesterday in the morning, hours before this thread was created :/



    Battle Royale fixed :)
     
    Last edited by a moderator: Jan 4, 2018
    adilahgaffar likes this.
  4. NebulaMask

    NebulaMask Active Member

    Yay! Working for me as well - Thanks to everyone :)
     
    Eurioin likes this.
  5. RazerSapiyo

    RazerSapiyo Community

  6. Marco5553

    Marco5553 Active Member

    It didn't work for me at that time yesterday as well. It does now though, so yours should too.
     
  7. MyNameIsToni

    MyNameIsToni Active Member

    didn't receive anything from OW either
     
  8. BrianRevy

    BrianRevy Well-Known Member

    Totally forgot to make the post yesterday when i realized lel but yeah the game is working as it should now to give zSilvers :)
     
    adilahgaffar and DestaKhoo like this.
  9. Coretex03

    Coretex03 New Member

    Confirm. It's working.
     
  10. ShoggyR79

    ShoggyR79 New Member

    Issues fix ladies and gents, Cheers!
     
  11. poh2ho

    poh2ho Well-Known Member

    Yay! Played a few games with my buddy yesterday. It was tough but quite awesome!
     
  12. OmnipotentXK

    OmnipotentXK New Member

    I am still unable to get any zSilver playing Battlerite.. sent feedback waiting for help now..
     
  13. MillAndre

    MillAndre New Member

    Can confirm. Had the same problem yesterday, it was fixed in about an hour. Having the same problem again right now.
     
  14. OmnipotentXK

    OmnipotentXK New Member

    Uninstalling, restart, and reinstalling Cortex doesn't solve the issue..
     
  15. Noisyboy8888

    Noisyboy8888 New Member

    The problem is back !
     
  16. JoviClaire

    JoviClaire New Member

    Hope they fix this soon! :frown_:
     
  17. PhrostByt

    PhrostByt Active Member

    down again for me
     
  18. Puppetier

    Puppetier Member

    Also down for me. Battlerite is not working either. They worked yesterday. Maybe it's a global issue?
     
  19. Hiffix

    Hiffix New Member

    Funny that i can't even send feedback since im stuck on "sending".....
     
  20. OmnipotentXK

    OmnipotentXK New Member

    Still not yet fixed? =\
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >