Found a Work-A-Round for the Synapse "Stalled" bug!!

Discussion in 'Razer Support' started by CrimsonX87, May 16, 2018 at 3:00 PM.

  1. CrimsonX87

    CrimsonX87 New Member

    Proposed Workaround: Wait for the installer to hang, mine did so around 25% to 71% depending on the method used. Then use Task Manager to kill the cmd.exe*32 process.
    (Aren't you glad you weren't forced to read all of the stuff below to try to find this?)

    ^Edit: OS: Windows 7<Fresh Install>
    Dual booted with Windows 10 for a backup OS even though I'm confident this fact is unrelated.

    ~~The :v: short :v: story below assumes you have done some research on this problem, or at the very least have read the first post of the thread linked below.~~

    Optional Reading
    So I felt obligated to throw this out there. First I tried the obvious, such as uninstalling\deleting EVERYTHING synapse related, swapping usb ports, catching up ALL windows updates, Updating .net framework, and so on. I also tried installing different versions. First i would install from the official installer obviously, but also tried to change/repair the failed installation from Windows' Programs and Features, which used an obviously different window to start the installer, and (An Assumption----->) a different process/service to get the ball rolling. Probably a 100 different other things as well. For real.

    This went on for at the least 3 hours a day for two days straight before i exhausted all my ideas... Finally I accepted defeat and started the Google research. That's around when i arrived at these forums for the first time ever : ). I found a few different suggestions, mostly stuff i had tried, every now and then I would find something new. Nothing seemed to pan out, and i began to notice all of the threads seemed to end with a Mod or Employee saying "If this isn't fixed contact tech support." or, "Sorry but this isn't a Support Forum."

    Then I came upon this thread that convinced me someone had managed to find a Solve/Work-A-Round;

    https://insider.razer.com/index.php...ean-install-asus-router-firewall-or-av.31142/

    My hopes were finally back up! I spent another day attempting this fix and of course when it didn't work, variations of this method. After using this method in combination with every previous method of my own and of those on the forums, and STILL FAILING, i gave up. I decided i must not have looked hard enough. Using the sites search system hadn't felt very effective, so using the tags system i dug through what i believe was every post on this site that made mention of this issue or anything similar. That's when i noticed the pattern and where i got the quotes from above.

    At this point I realized, "So if this isn't a Support Forum then that's where i need to go!" So after spending an hour or two on Google again, the best idea i managed to find was to do a Clean Boot and install from there (I believe i had seen that suggested in a thread here and it was one of the only things i didn't try). Again my hopes were dashed, especially because i had had to figure out which services to enable to get the installer to run in the first place.

    **I was also heavily invested on trying to get networking back up so I could attempt to run the Synapse updater service. After I had re-enabled about 6 different network related services to no avail, I gave up on that.**

    Studying the processes and killing them off in Sysinternals Process Explorer had taught me that CMD.EXE was being used to modify a .dll file and would hang every time. I cant remember name but it was a .dll file located in the Windows folder. At the time i had decided it would be better to leave said file alone since I didn't know if it was critical to other services. It was not the "process" mentioned in the other thread, and therefore it was never opened as a service or a process to be killed.

    Still in clean boot, that's when i decided to try another suggestion i had seen repeated several places including here; slowly killing different Razer processes one at a time till the installer starts moving again. This wasn't the first attempt at this though lol. Of course this didn't help either, just like it hadn't helped me before. For whatever reason, that was when it clicked. I killed off cmd.exe BEFORE killing the installer, which i had done in reverse dozens of times previously. A few seconds later, the installer showed life again! It wasn't all at once, so if you attempt this, don't assume it didn't work for at least the first 30 seconds as your mileage may vary.

    It would be nice if at least one person takes the time to read of my pain, as this is truly the just a summary of my struggle with this glitch. Even more so I hope that this saves everyone else from here on out from wasting even a fraction of the time i did.
    : )
     
    Last edited: May 16, 2018 at 3:25 PM
    ARMOR_152 likes this.
  2. CrimsonX87

    CrimsonX87 New Member

    just discovered the headline at the top that announces a new support section, also realized I dont remember seeing the options for choosing which board to post in. With that said i have almost certainly posted this in the wrong area....

    If possible can a Mod move this thread to where it belongs instead of just deleting it? Just a glance will tell you I invested more time then i probably should have with this entire thing, including the debrief lol.