GameDog [v2.4] - Chroma for CS:GO and DOTA2

Discussion in 'Razer Chroma' started by WolfspiritM, Oct 26, 2015.

?

Is it useful and would you like to see more from this Project?

  1. Yes

    491 vote(s)
    96.8%
  2. No

    16 vote(s)
    3.2%
Thread Status:
Not open for further replies.
  1. Hello there,

    The profile of puffnpluky76 is not working properly on my rig. The only switches that are lighting up are ZQSD (azerty keayboard) and the 1 and 2 switch.

    So I have the chroma v2 version in azerty, I'm asking myself does the gamedog work properly with chroma v2 keyboard or azerty ones?

    I really don't see why it is not working properly.

    Thanks for your help.
     
  2. SgtDeathAdder

    SgtDeathAdder New Member

    Thank you very much OP! Will be using it for Dota 2
     
  3. GannyX

    GannyX New Member

    oh sweet :D I love this


    maybe for paragon?
     
  4. LucasBB

    LucasBB New Member

    Any info on the Fallout 4 integration? Anxious to see it :wink_:
     
  5. Is it working in ornata chroma? Because im trying to and its not actually working. Thanks
     
  6. I'm very impressed with these settings of Gamedog! Especially the Razor ripple effect.

    Can you tell me how do you config that ripple effect on that Razor skill? I would like to make the same ripple effect as when Invoker invoke a spell and the moment I press R(Invoke) the ripple effect will trigger depends on which spells i invoked and what ripple colour it will be.

    Also is it possible to make the QWE changes to Blue,Purple,Red whenever the keys are pressed down?

    Help would be much glad!
     
  7. KeithChan_no_id

    KeithChan_no_id New Member

    Hello,

    Thank you so much for the app! However quick question, does it work with lancehead?

    Or it basically applies to pretty much to all of chroma enabled devices?


    Thank you!
     
  8. giang.dat_no_id

    giang.dat_no_id New Member

    upload_2017-7-21_14-23-54.png
    How to fix it :slightly_sad:
     
  9. WolfspiritM

    WolfspiritM Active Member

    I still have a prototype available for Fallout 4. The initial Fallout 4 integration I made sadly stopped working as Bethesda made a Fallout 4 update and FourDragon (the scripting engine I used) hasn't been updated for nearly 2 years... I found a basic workaround using the Fallout 4 Companion App's "API" which however is kind of limited and a bit hard to use. If I get some time I will add that...I told myself I won't ever play and finish Fallout 4 without Chroma Integration ;) So I have to do it sometime soon...

    The Razor Ripple Effect sadly is not customizable (yet) and is stuck to Razor and it's spell. I wanted to add effects for other spells, too, but didn't get the time yet.

    The Razer Chroma SDK just targets device-groups not individual devices. So besides some special cases (Deathstalker for example which only has zones) it should work for all Chroma devices (even new released ones). I however have not tested it with the Lancehead directly so I can't say for sure.

    The RzSDKServer.exe is not the RzSDKService.exe. That are two different things. Make sure the Service is running. Press Windows + R, type "services.msc" and press Enter. In that list check for "Razer Chroma SDK Service" and that it's status is "Running". If it isn't try rightclick and click "Start".


    -----------------------------------------------------------

    Anyone interested...

    I have updated the backbone of GameDog to use the new REST API instead of the C++ SDK.
    I tried to make it as smooth as it was before even so the REST API isn't as fast as the direct C++ one (it's more stable however). I would love to get some feedback if it's faster/slower/smoother...
    It's not an official Release but you can get it here for now:
    https://1drv.ms/u/s!AiA2S8qhAF0ggYYBfZU_btgk_M2riw

    Still hoping to get the new UI done soon.
     
    Last edited: Jul 23, 2017
  10. cherokeeee

    cherokeeee New Member

    Thanks. I'm trying this later and will report. Maybe this works better for me than the C++ version. I had stutters and low performace, noticeable on my 144hz monitor (i7-6700k GTX 1070)

    EDIT: Nope, still too laggy to me. Can't use it sadly :slightly_sad:
    Btw the lightning is perfectly synced to the game. It works fine!
     
    Last edited: Aug 11, 2017
  11. WolfspiritM

    WolfspiritM Active Member

    Laggy? That's strange. Do you have it running minimized? That should improve the performance at least a bit
    Are you using it for Dota (I assume as you said lightning) or CS:GO? I might have some improvement for CS:GO but sadly not for Dota.
     
  12. the lighting doesn't turn on, it just flashes when I fire in game
     
  13. Ayciate

    Ayciate New Member

    Hey dude, any updates on your Factorio Chroma? Currently is it out out date, thanks!
     
  14. rrodkk

    rrodkk New Member

    Hey razer i got an error with this link that says your connection is not private how df fix that :/
     
  15. vagikil

    vagikil New Member

    I have followed your installation instructions.
    I launched Synapse, then launched GameDog.
    Once GameDog launches my Blackwidow Chroma cycles green from top to bottom of the keyboard then goes black(unactive).
    When I goto a line item to change it and hit "Save" the F9-F12 keys are Blue and PRT SCRN - PAUSE BRK are green.
    I launch Dota 2, go in game and the keyboard is a very dimly lit green and it has no interaction with spells, items, clock ,denies or anything.

    I have already uninstalled in "program and features" the Synapse and Chroma SDK applications and still no changes to these problems.

    Is there anything I am missing?
    Thanks~!
     
  16. rrodkk

    rrodkk New Member

    LOL bro u didint help me my error is in google with the link also with microsoft edge and moxilia and with my phone and with my laptop i think that is the link
    Hey razer i got an error with this link that says your connection is not private how df fix that :/
     
  17. cherokeeee

    cherokeeee New Member

    Yep, since first release (i come here and try from time to time to see if it gets fixed) it makes my gameplay more laggy, it's something hardly noticeable but it bugs me, it's like a micro strutter lag. I don't know why does it happens, I'd love to use your software, I even donated time ago when I had a 60hz monitor, but now on my 144hz it lags too much :slightly_sad:

    EDIT: Forgot to say I'm using it exclusively on csgo and yeah, i've tried every option/combo: minimized, tray, open.
    I have other apps using the csgo API: Steelseries Gamesense, Plays.tv . Maybe is that a problem?
     
  18. WolfspiritM

    WolfspiritM Active Member

    What Keyboard are you using?
    Usually that is how the Deathstalker would work, but you said it's cycling from top to bottom which shouldn't be how the deathstalker works.
    Try resetting the layerin GameDog (Go to "Dota 2" in gamedog and click on "Reset").

    I know what you mean and sadly I think I can't do much about it as it's on the CS:GO side. Especially as Valve broke the game integration I now have to force CS:GO to send updates as fast as possible instead of when they change. HOWEVER I'm trying a few things including telling CS:GO to not send updates as quick as possible but with a half a second delay. This might fix the micro stutters.
    Could you contact me via Steam please?
    Would be nice to get a few informations when it comes to the other CSGO APIs.
    https://steamcommunity.com/id/kiba/
     
  19. WolfspiritM

    WolfspiritM Active Member

    I don't plan on updating Factorio Chroma right now. It was using heavy writes on disk and was more like a proof of concept. I didn't like how it worked (even so it was the only way back then), so I opened up a thread on their forum asking for any way for mods to "talk out of the sandbox" to provide the needed Data instead of just writing to a file, but the Developers didn't see it as needed. I don't think anything changed when it comes to that as they want mods to be sandboxed completly.

    If you have further questions please send me a private message here and keep this topic to GameDog, CS:GO and Dota. Thanks! :)
     
  20. kongzter_no_id

    kongzter_no_id New Member

    Why is it that only the team color is working in Dota2??? by the way im using deathstalker chroma
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >