GDPR: WTF Razer?

Discussion in 'Razer Synapse' started by DreadPirateLynx, May 17, 2018.

Thread Status:
Not open for further replies.
  1. DreadPirateLynx

    DreadPirateLynx New Member

    My understanding is that with the May 25 GDPR update, Synapse 2.0 will be dead. Meanwhile, 3.0 still doesn't list support for my hardware. WTF Razer?
     
    jackcastrov likes this.
  2. Joikansai

    Joikansai Well-Known Member

  3. DreadPirateLynx

    DreadPirateLynx New Member

    The really need to work on their verbiage when making these kinds of announcements. The email makes it seem as though Synapse 2.0 is being dropped completely.
     
  4. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    I can reconfirm what @Joikansai mentioned. Synapse 2 is NOT dead, it will be updated to comply with GDPR. Older versions of Synapse 2 (or Synapse 3 or Cortex for that matter) will no longer be able to login to our servers as they are not GDPR compliant.
     
  5. Qlmmy

    Qlmmy New Member

    Thank you for clarifying! I though I was going to loose all my macros and profiles that you still haven't made possible to bring over to synapse 3.
     
  6. Hi, can I still update my version after may25th?

    what can be the major changes on my current settings after this update?
     
    Last edited by a moderator: May 26, 2018
  7. FiszPL

    FiszPL Well-Known Member

    Yes. Update will always work, the only thing that will not work is login to the old version.
     
  8. My razer synapse version is currently now 3.3.517.51518, so this is updated? Thanks a lot.
     
  9. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Yes, that is the latest version and is GDPR compliant. :)
     
    greatDarkLavapoint414 likes this.
  10. Thanks for letting me know. Cheers!
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >