HELP: Cannot open Razer Synapse 2 software on W10!

Discussion in 'Razer Support' started by RoscoeTheDog, Dec 19, 2019.

  1. RoscoeTheDog

    RoscoeTheDog New Member

    OK everyone. I just purchased my Razer deathadder and I'm appalled at the software that was advertised with it. I like the mouse, but I cannot get the Razer Synapse 2 software to open. I've even tested it on multiple different Windows 10 systems (desktop and 2 other laptops). All machines have been fully updated, and tested on 2 different networks in order to see if a firewall or other node could be blocking the programs connection and preventing it from opening.

    I'll install the software, sign in like usual, then the Razer Synapse software gets minimized to the tool tray. Nothing too out of the ordinary. However, when you right click and hit "open", absolutely nothing happens. I cannot get the application open no matter what.

    This is very frustrating of course, since a lot of the gaming mouse's functionality is lost without this proprietary software.

    I have created a support ticket, which has gone unanswered for the last 2 business days now. The ticket is #191218-000250.

    I have tried the following, as suggested by numerous other threads:

    1) uninstalling the drivers manually, then the uninstalling software and reinstalling everything fresh.
    upload_2019-12-19_20-8-34.png

    2) disabling all antivirus and firewall software
    upload_2019-12-19_20-7-5.png

    3) booting into Windows Safe Mode
    *I apologize I do not have a screenshot for this*

    4) checked all Windows updates (and ensured .NET framework has been installed)
    upload_2019-12-19_20-9-48.png
    upload_2019-12-19_20-6-0.png

    This seems to be a common problem on Windows 10 systems for a very long time! How has this bug not been resolved yet? What can I do to get it working at this point?
     
  2. Lusabit

    Lusabit Active Member

    Contact support (or easier: change to better devices)
     
  3. RoscoeTheDog

    RoscoeTheDog New Member

    That's not really helpful. I already have contacted support and they have been MIA. I am hoping that a Mod or someone on these forums could rectify this issue.
     
  4. Lusabit

    Lusabit Active Member

    Hmm, I can't believe that support can not help you. Ok, which type of Deathadder did you buy ?
    Syn2 only supports DeatAdder Chroma.
    For any other you have to use Synapse 3 ! If so, uninstall Syn2 completely, delete all files on disk, that may resist, if possible clean your registry, if know how.
    Than download and install Syn3 (or follow my last proposal, easier).
     
  5. RoscoeTheDog

    RoscoeTheDog New Member

    This is the exact one I bought:
    https://www.ebay.com/itm/3500-DPI-O...e=STRK:MEBIDX:IT&_trksid=p2057872.m2749.l2649

    Seems to be the correct one. The original box mentions synapse 2 specifically as well.

    The thing is, it seems I cannot open the application whether or not the mouse is plugged in or not. Even if the mouse is unplugged, I should theoretically be able to open the program.

    As I mentioned before, I tried this on my desktop and laptop computers. Both have relatively fresh installations of Windows 10 pro x64 bit (fully updated). I thought it may be a software/driver conflict with another program, but if that were the case then booting into safe mode shouldn't reproduce the problem.

    I like the mouse. It's one of the few that fits my hand well and is affordable. I do not exactly want to return or shelf it. This software is turning out to be a headache though!
     
  6. Lusabit

    Lusabit Active Member

    Hmm, complicated. On the Razer Page there is no DeathAdder Elite Chroma.
    You find DeathAdder Chroma (needs Synapse 3)
    or DeathAdder Elite (needs Synapse 2)
    This is Raszer horrible driver production, we are complaing since years, and nothing gets better.
    This should be a clear case for Razer Support,
    which seems to fail one more with your problem.
    (https://support.razer.com/gaming-mice-and-mats)
    https://windowsreport.com/razer-synapse-open/: perhaps you have to install the .Net Frameworks
    "Razer Synapse 2.0 requires "Microsoft .NET Framework 4" to be installed"
    So download the latest 4.xxx 64Bit Version from Micrsosoft and install it.
    Good luck.
     
  7. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Moving to Support Section.

    And for the record, both the DeathAdder Elite and the DeathAdder Chroma are compatible with Synapse 2 for PC.

    The DeathAdder Elite is ALSO compatible with the Synapse 3, but the older DeathAdder (which looks to be what you have, according to the box - I don't see a mention of Chroma on the box, just in the ebay listing) is not.

    I believe that @Lusabit was referring to the DeathAdder ESSENTIAL when he was talking about one of the DeathAdder family of mice only being compatible with Synapse 3.
     
  8. Lusabit

    Lusabit Active Member

    From the devices list for Syn3:
    upload_2019-12-21_17-27-35.png
    for Syn2:
    upload_2019-12-21_17-29-24.png
    There is no DA Elite Chroma!
    so, if it's a DA Chroma it has to use Syn2,
    if a DA Elite, 2 or 3.
    Or support informations are false.
    But however, will be another problem, Syn2 should recognize it, but I'm not support.
     
  9. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey there! There's no Deathadder Elite Chroma as we only have Razer Deathadder Elite. However, the Razer Deathadder Elite is different from Razer Deathadder Chroma. Byt the way, if a device is listed both the Razer Synapse version and installed in your computer, the device will be detected in Razer Synapse 3.0 only. You can uninstall Razer Synapse 2.0 if you don't have any device using it. To see the list of compatible for each Razer Synapse version, please refer to the links below:

    https://support.razer.com/software/synapse-2.0/ - Razer Synapse 2.0
    https://support.razer.com/software/synapse-3/ - Razer Synapse 3.0
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >