Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

HELP! Viper Ultimate Problem

Discussion in 'Mice and Surfaces' started by Malademental, Sep 9, 2020.

  1. Malademental

    Malademental New Member

    In Synapse, they said when I put my mouse on charging dock the led will indicates the battery status.
    BUT IT DOESN'T WORK!

    I tried reinstall the mouse driver and synapse, but it always doesn't work.
    Of course, charging function works well. Just battery status indicator doesn't work.
    Rarely It works, but when I use mouse (mouse off the dock) it continues the battery indicates.

    And surprisingly, the all problems don't occur when I use viper on other computer, not on my laptop.
    Does anyone know why?

    p.s : Sorry for bad English... I'm not American
     
  2. FiszPL

    FiszPL Well-Known Member

    I'd try different USB port first, then if not helps try creating new (empty) profile to check if it will help.
     
  3. Malademental

    Malademental New Member

    I tried all of my port, reinstalled my device and synapse many times but it doesn't work.
    And I don't know why it is happening only my laptop. It's my main machine...
     
  4. FiszPL

    FiszPL Well-Known Member

    Reinstalling should look this way: uninstall synapse, then go to your device manager in OS - remove all razer peripherals from device list (also select to delete drivers). Then use a CCleaner app to cleanup your PC, and more important cleanup the windows registry. After PC reboot install Synapse 3 software again.
     
  5. Malademental

    Malademental New Member

    I tried it, but it's not working. It works well on desktop, so it's my laptop problem but don't know what it is...
     
  6. BioZ_UA

    BioZ_UA New Member

    I have the same issue Synapse messed up with a charging and lighting efects of my Viper Ultimate

    The thing is that if you put it on a charging dock, only after couple of minutes it will indicate that it started charging and switch the lighting to the charging mode, but after I pick the mouse up from the dock it will never go back to the usual lighting and Synapse will still indicate that mouse is charging

    Only if I unplug the transmitter from the dock and plug it back in it will understand that mouse is not charging anymore

    Without Synapse launched charging and lighting works fine.

    I tried reinstalling drivers and synapse, updated the mouse and dock firmware, cleaned it with CCleaner, no luck.
     
    MrChupul likes this.
  7. LiLmEgZ

    LiLmEgZ Active Member

    Hmm that is interesting... and I hear nothing but nice things about the Viper Ultimate from most people that have one :confused:
     
  8. jedramos

    jedramos Well-Known Member

    hope they find a solution to this problem. try asking on reddit or fb mouse groups
     
  9. BlackFireDragon

    BlackFireDragon Well-Known Member

    @Malademental Can you tell me few things what kind of pc you use, you have synapse 3 working in back ground when you put mouse on dock, when mouse is on dock is visiable on synapse and what is the dock status when you enter it via synapse.
     
  10. MrChupul

    MrChupul New Member

    Also experiencing the same issue. i tried to close razer synapse and the delay in charging light and the stuck charging light disappeared. Downside is i cannot set rgb if synapse is closed. I think it is a problem in synapse? not sure. hope someone can help us
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >