Help with freshly new Razer Naga Epic Chroma

Discussion in 'Razer Support' started by rushAliceBluesight337, Sep 2, 2018.

Thread Status:
Not open for further replies.
  1. Hello, everyone im desperate, so i really hope you guys can help me.

    I decided to change my 6 years old Razer Naga (The first one), i was very pleased by it since i'm a RPG player, so i decided to go for something about the same, but much better, so i bought a Naga Epic Chroma, it felt so good in my hands, the handling, the buttons, everything, and i was so thrilled to try it.

    I just arrived home, and plugged it in wired mode and it won't work .

    I've tried in wired mode, wireless mode, i downloaded the Synapse app, i restarted, and i've tried in many different ways. I've looked for info, i've browsed to the last page of google to see if i can fix it, and i haven't been able to fix it.

    Everything works, the click, right click, scroll buttons, page back, page forward, buttons at the side, everything works, but the cursor. It won't move.

    So i don't know if the laser is broken, and if it is, i bought it in a different country, from the same authorized dealership that i bought my previous one.

    I don't know what to do, please help.
     
  2. Razer.Winteryang

    Razer.Winteryang Ice Bear

    Is it possible if you can test it on a different computer to isolate the problem? Feel free to drop us a PM with the serial number of the mouse if you need further help with this.
     
    freakydoctor likes this.
  3. Guesswho1

    Guesswho1 New Member

    I'm having a similar problem. The mouse works fine wireless. It connects to the dock and charges it's battery just fine. It just won't connect while wired via USB, On or off. I tried on a different laptop and it just won't work.
     
  4. Razer.Winteryang

    Razer.Winteryang Ice Bear

    Hey there, sent you a PM to help you out. Please check your inbox.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >