How to go about recovering data from a boot loop stuck Robin?

Discussion in 'General Q&A' started by mr-toosmooth, Dec 10, 2017.

Thread Status:
Not open for further replies.
  1. mr-toosmooth

    mr-toosmooth New Member

    Hello my lords and soon to be saviors. One day I woke up and my Robin just wouldn't turn on. Stuck on the Nextbit logo and keeps rebooting. I've tried pretty much everything. The functionality of the device isn't top priority, the data however is very dear to me. Contains all the pictures of my semester abroad and lots more. And yes, I didn't enable the cloud service. Extremely stupid of me since that's the main selling point of the phone.

    I assume it tried to update the OS while I was asleep and something went wrong. But it also got through the boot loop one time, and booted successfully but crashed as soon as I started using it. The phone's been sitting there for weeks now. I don't dare do a factory reset. Any help would be appreciated.

    Thank you.
    -Robin

    -Yes my name is Robin too :) -
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >