Huntsman elite keyboard, letter 'e' not working

Discussion in 'Razer Support' started by carautoFirebrick945, May 28, 2021.

Thread Status:
Not open for further replies.
  1. carautoFirebrick945

    carautoFirebrick945 New Member

    Hi all,

    I have just begun to have a problem with the 'e' key on my keyboard, otherwis it has been a great device.

    I have tried to do the esc + caps lock + space bar combo to try reset it.
    I have tried another device.
    I have tried different USB ports.
    I have cleaned underneath it, nothing there.
    I have updated firmware and drivers.
    I have tried without the wrist rest.
    I have tried closing all Razer software and testing it.

    The strange part is that it will somtimes work out of the blue, but then stop working again.
    Also, the 'e' key still lights up, but in Synapse, when i press the other keys they ripple, but when I press the 'e' key, it does not ripple actual lights or the lights on the program.

    Any suggestions or help will be appreciated.

    I tried Razer support, but my warranty ran out it seems and they do a good job of blocking you out and not letting you contact them. (If I am wrong, happy to be told).

    Thanks
     
    Blushrabbit likes this.
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Were there any incidents that happened before the issue? Does the issue occur while Synapse is closed or disabled? Send me the serial number of your Huntsman Elite via PM and let's continue our conversation there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >