Huntsman Elite spring pinging sound

Discussion in 'Keyboards' started by Predator5, Apr 10, 2021.

  1. Predator5

    Predator5 Well-Known Member

    Hello,

    My Huntsman Elite is producing this high-pitched pinging sound on some keys when they actuate. Sometimes depends on the angle of the press, as in it's sometimes not heard if the key is pressed right in the middle. I don't think it's the stabilizer bar, as it's not like in the other videos I found, and I actually haven't found one with this issue.

    You can head the difference between T which doesn't do the sound no matter how you press it, and R, which does it basically always if you don't press it right in the center.



    Anyone else having the same problem? I don't think this is normal. About 30% of the keys do this.
     
    pancholr likes this.
  2. Joikansai

    Joikansai Well-Known Member VANGUARD

    I don’t have huntsman elite but on new huntsman mini and old BWX Te, I don’t have it. I thought it was somehow from Audio pheriperal like nommo chroma but when I tried it doesn’t have any high pitch sound, because sometimes that nommo brings high pitch sound when I use it on multiple device like with audio cable on monitor for PS4 pro and usb to my Blade, continually high pitch sound though not like that.
     
  3. Predator5

    Predator5 Well-Known Member

    I think you're mistaken, the sound comes from the switches themself, not from the speakers.
     
  4. Joikansai

    Joikansai Well-Known Member VANGUARD

    Yes I thought some how from audio device, weird I don’t have it at all on my mini nor older mechanic keyboard even on my mechanic usb numpad, I think I never see such things as well, well maybe because I’m less putting attention to keyboard posts. Did you try to open it and see if it has any changes or maybe by using some liquid to lube it? Not really keyboard guy, and I never even opened the caps on my 4 years old BWX te.
     
  5. Predator5

    Predator5 Well-Known Member

    It's still under warranty, that's why I didn't open and lube it. It's producing that sound from the first day I got it.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >