Huntsman Elite Volume wheel - Skipping levels & working on its own

Discussion in 'Keyboards' started by AlexPilon666, Apr 13, 2019.

Thread Status:
Not open for further replies.
  1. AlexPilon666

    AlexPilon666 New Member

    Hi everyone,

    Bought a Huntsman Elite in July of 2018, and a few months ago I've started noticing that the volume wheel is acting up in three different ways:
    1. When using it, the volume will jump up and down, no matter if I try and raise or lower the volume
    2. Instead of adjusting the level by 2 points, it'll jump by anywhere from 2 to 20 points at a shot
    3. The volume will sometimes just change by itself, when the keyboard isn't even remotely being touched
    Problems #1 and #2 I've had happen with different non-Razer mice in the past, and I always ended up having to purchase a new mouse.
    Problem #3 though is just weird.

    I'm thinking it might be my computer acting up, but I'd have to reinstall my OS to figure it out (I don't have another Windows computer at home for testing).

    My current setup is as follows:
    - Windows 10 Pro x64 v1809 fully patched as of time of writing
    - Razer Synapse v3.4.401.32710

    Has anyone else experienced that issue with that keyboard ?

    Thanks!
     
    0V3R_K1LL, Kylos77 and pancholr like this.
  2. BlackFireDragon

    BlackFireDragon Well-Known Member

    When you slide wheel by little you feel the force of buton and the "click" from it ?
     
    pancholr likes this.
  3. AlexPilon666

    AlexPilon666 New Member

    Yup, I do. I feel a single click, not multiple, and then the volume jumps all over.

    I went on support chat yesterday, was given an RMA, but would really like not having to lose access to my keyboard for 2 weeks, if there's an actual fix!
     
    pancholr and Kylos77 like this.
  4. BlackFireDragon

    BlackFireDragon Well-Known Member

    You remember when the issue start if there was any accident or update in windows or any other app on your pc ?
     
  5. AlexPilon666

    AlexPilon666 New Member

    Started happening too long ago, I'd say easily 4-5 months, so there have been multiple Windows and application updates ever since.
    I only flagged it now because it started changing the volume on its own, which is both creepy and annoying hehe

    Yesterday with support we tried running the keyboard on different USB ports, while making sure all Razer apps were closed: no success.

    I found in Razer's FAQ for the keyboard that there was a firmware update. Did it, still didn't help.
     
  6. BlackFireDragon

    BlackFireDragon Well-Known Member

    In this case i can only recommend you cheacking it on difrent pc if you dont remember if something was change before the issue. This give you clear info where the issue is if on difrent pc the issue dont show up the problem will be on your pc hardwere but most likly softwere if appear the issue will be on keybord pcb itself and on your own you do anything without loseing warranty.
     
  7. AlexPilon666

    AlexPilon666 New Member

    While on support chat, I dug up my old Macbook Pro 15" with Linux on it, plugged the keyboard in it, and the same issue persisted, thus proving the issue seems to be hardware related, as my Linux install obviously has no Razer software whatsoever, only default keyboard drivers.

    Kinda always knew it was hardware...was just hoping there was some miracle solution where I wouldn't have to send it for RMA hehe

    Thanks for the help!
     
  8. BlackFireDragon

    BlackFireDragon Well-Known Member

    IN this case the best will send it to get repalce unit. On your own you dont repair the issue ;/
     
  9. AbelBoni06

    AbelBoni06 New Member

    I'm having the same issue with my Razer BlackWidow Elite Multi-function Digital Dial(Volume Wheel). The volume doesn't change consistently but as you said, skips levels. Like this: https://streamable.com/o4h0d
     
    Kylos77 likes this.
  10. BlackFireDragon

    BlackFireDragon Well-Known Member

    On the video dial works as should be. Dial change volume level by two not one :stuck_out_tongue_winking_eye:
     
  11. SharpSpringFrost

    SharpSpringFrost New Member

    Same issue here on my 1 month old Blackwidow Elite, thought I was the only one.

    Although not as severe as the op's huntsman elite, it is still annoying that the volume jumps back and forth when I change the volume using the volume wheel.

    Anyone knows how to fix this?
     
    Kylos77 likes this.
  12. Kylos77

    Kylos77 New Member

    I have this same issue with my Blackwidow Elite Media Dial.

    Similar to what OP described, when using my media / volume wheel,
    1. The volume will jump up and down, no matter I turn the wheel clockwise or anti-clockwise. The result is taking 4x as long to adjust from volume 0 to volume 100 because its always trying to shutter back.
    2. Each click in the wheel is supposed to adjust the volume by 2 points, but now it'll jump by anywhere from 0 to 6 points at a time.
    3. When I am in a game, using the volume dial will also randomly trigger the keys C and B (specifically).

    Any one has figured out how to fix this, that would be of great help, thank you.
     
    DRIFT_IT likes this.
  13. PaperzMask

    PaperzMask New Member

    facing exact same issue since May's synapse 3 update (after that ambient add on)
     
    riddler94 and Kylos77 like this.
  14. riddler94

    riddler94 New Member

    I just bought the keyboard and the multimedia dial is have same issue :slightly_sad:
     
  15. PaperzMask

    PaperzMask New Member

    I tried to plug in this keyboard to my laptop & other PCs too, I think the dial itself is faulty.
     
  16. creeperboycraft

    creeperboycraft New Member

    still is not working for me this is annoying :/ razer needs to fix it
     
  17. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    To everyone experiencing the media wheel issue, please send me a PM with the serial number of your keyboard along with your Windows Build Number and Synapse Build Version. I'll need all of those to try to recreate the issue on my end and work on a proper fix.
     
    rayd89, 0V3R_K1LL and DRIFT_IT like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >