Huntsman mini broke my windows

Discussion in 'Razer Support' started by aaccensi, Nov 11, 2020.

Thread Status:
Not open for further replies.
  1. plagueseason

    plagueseason New Member

    Seems like anything that was made in 2018 or earlier do not exhibit the issue - so their V2 line of products, or the Huntsman Elite.
     
  2. plagueseason

    plagueseason New Member

    If any of you did replacements as a step to troubleshoot this, make sure they didn't close your ticket after the replacement process was complete. This happened to me, despite me telling them the issue was still present, and I needed to open another ticket. Hold them accountable and make sure this issue gets tracked.
     
  3. arsenic13

    arsenic13 New Member

    Came to this forum for the first time to see if anyone else had this issue (windows and taskbar freezing up after random amounts of time) and if it was safe to re-download Synapse... I guess not.

    I didn't know Razer was at fault a few months back, so I did a fresh Windows install (for no reason). But since I found out it was causing the Windows freezes, I uninstalled Synapse and things have been normal.

    I don't know which product might be the culprit when interacting with Synapse, but I own the following:


    Razer Huntsman Elite
    Goliath Mousepad (which would disconnect quite often when I had Synapse installed)
    and the Basilisk Ultimate
     
  4. ak5hat

    ak5hat New Member

    They are asking me to cut the cord and peel off the label at the back of the keyboard in order to issue me a replacement. they have denied the problem exists and have refused to replace it with any other model or even huntsman elite. i really cant believe this. they are really in for a class action lawsuit if this continues on.
     
  5. HaTrED._

    HaTrED._ New Member

    Came across this thread when i was looking for some answers regarding my issue - Windows 10 taskbar freezing after logging in.

    In my case, i'm able to replicate this problem with a Ornata V2 Keyboard, a keyboard model that doesn't seem to be mentioned in this thread! Looked for some updates regarding it's firmware but they are inexistent...!

    MSI MAG X570 Tomahawk WiFi with an AMD Ryzen 5600x - latest chipset driver's and windows update.
     
  6. plagueseason

    plagueseason New Member

    Perhaps some light at the end of the tunnel for Huntsman TE owners. Got a reply from support today that read a bit different than the usual responses so far:

    "We wanted to let you know that we have managed to identify the cause of the issue that you have reported. Due to the complexity and the work that needs to be done, we are unable to provide an estimate of when you can expect a fix. However, once a fix has been identified, this will be released in a future software update."
     
    6892045704592621569 likes this.
  7. 6892045704592621569

    6892045704592621569 New Member

     
  8. LucasWalker007

    LucasWalker007 New Member

    Support responses that I also received on this topic and still no ETA for its resolution :frown_::
    • End of july : "our team is aware of this issue and they are still working on the solution to this problem. However, we don't have any ETA yet for the solution"
    • Yesterday : "we had this forwarded to our Development Team, and they are aware of the said concern, but due to the complexity and the work that needs to be done, we are unable to provide an estimate of when you can expect a fix."
     
  9. plagueseason

    plagueseason New Member

    At least it seems like they know what's wrong now, I hope. Glad to see they're sending similar communication to others. Shows that it's officially on the radar on their support side.
     
  10. Dicehunter

    Dicehunter New Member

    Well for whatever reason this issue seems to have returned. I shutdown my rig, Plug my Corsair K65 Mini in, Boot up and no issue at all, If I have the Huntsman Mini plugged in upon windows booting it gives me issues.

    This type of issue shouldn't exist, If Corsair, Glorious, Ducky and Asus aren't having this issue with their 60% keyboards then there's obviously something broken on the firmware side of things with the Huntsman Mini.
     
    Last edited: Sep 3, 2021
  11. BuryTheDead

    BuryTheDead New Member

    Just a heads up to any other Users having the same issues as what others and myself had with the Huntsman Mini Keyboard.

    Razer have uploaded Firmware for the Keyboard which would only affect Users with AMD Processors in their PC's.

    https://mysupport.razer.com/app/ans...r-huntsman-mini-firmware-updater-|-rz03-03390

    Hope this helps if anyone else has experienced this issue. Someone probably has put this up already but just putting it out again so people can find it more easily through this thread.

    BuryTheDead / James
     
  12. Dicehunter

    Dicehunter New Member

    That was more of a band aid to the issue rather than a proper fix as many, Including myself, Intermittently still have the issue even after updating the firmware.
     
  13. jonpark2

    jonpark2 New Member

    I second this. I have huntsman mini, and I use it with Ryzen 4800H laptop. Ever since Microsoft automatically updated Razer HIDClass driver, keyboard became slow and feels like there is ghosting when moving around using WASD keys.
     
  14. FiszPL

    FiszPL Well-Known Member VANGUARD

    @Razer.Speedcr0ss I'm on the same boat, having issues with Windows 10 explorer.exe crashing.
    I'm on AMD platform (Ryzen 5 3500X, but B450m chipset: MSI B450m Mortar MAX motherboard, with newest available BIOS update). I'm using Razer BlackWidow V3 keyboard.

    As far as I know these 3 keyboard are causing the issue: Razer BlackWidow V3, Razer Huntsman Tournament Edition, Razer Huntsman Mini.

    I've already submitted a case to Razer Support, but it'll be good if the case could be "connected" with other AMD user cases, that are using one of the 3 mentioned keyboards.
     
  15. arsenic13

    arsenic13 New Member

    Has this been resolved for Intel users? I have the same explorer freezes but am using an i7 7700k. It's been months since I've had Synapse installed and am curious if it's safe yet.
     
  16. I have the exact same issues, long windows log in and hanging / non working taskbar with my Hunstman TE plugged in. I run a 3900x with a Asus B450-i Mobo.

    I cannot believe this issue has still not been fixed and no firmware update for the TE yet, shocking support. I thought long and hard about sticking with razer after I had 2 deathadder mice develop double click faults, and now this. I will not be buying or recommending Razer again.
     
  17. Gimp2004

    Gimp2004 New Member

    I'm having the same type of issue but I don't have a Razer keyboard. I did however just buy a Razer Naga Pro and and the mouse dock. I don't think the Naga Pro is the issue and I think it could be the dock. I'm troubleshooting at the moment to make sure.
     
  18. aranth

    aranth New Member

    No solution yet for either Amd or Intel. I suppose this will only be fixed with a keyboard firmware update but it's been months (nearing a year now) since this bug was posted on the forums and here we are still waiting for even some official acknowledgment from Razer that they are even aware of the problem and working on resolving it (and no, some random support representative telling you they are on top of it doesn't really count as they are usually the last ones to know).

    It's been really disappointing yet not at all surprising to see Razer ignoring this problem, most companies only care about selling their stuff to you and not supporting their own customers.
     
  19. ak5hat

    ak5hat New Member

    they have released V2 of huntsman keyboards. does anyone know if this problem is fixed in that or not
     
  20. chillpod

    chillpod New Member

    Yha I want to know too. I messed my pc with the v1 series.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >