Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

I can't Open Synapse 3

Discussion in 'Razer Synapse 3 Beta' started by 1wangand4, May 14, 2020.

  1. 1wangand4

    1wangand4 New Member

    Gaaah...
    I'm running Windows 10 Pro 64-bit, and I can't open Synapse 3, no matter how many times I try.
    I've tried reinstalling countless times, I've ran it as administrator, and I've tried all of the solutions online, but it still doesn't work. Help!
     
  2. JoshuaHuman

    JoshuaHuman New Member

    Same here. Really frustrating after just buying four of their products.
     
  3. 1wangand4

    1wangand4 New Member

    I know, right? They have Synapse 2, which has been dubbed "legacy" and is no longer compatible with new products. And they have Synapse 3, which is still in Beta and still encounters all the problems with beta apps, after all these years.
     
  4. Cayleb

    Cayleb New Member

    Any luck with this issue? I'm experiencing it as well, and it's super-frustrating to not be able to reprogram my Tartarus V2 or tweak my Nari Ultimate.
     
  5. 1wangand4

    1wangand4 New Member

    I don't know. This post was made a while ago. A little after this post was made, there was an update for Synapse 3 and that fixed the problem for me. I just have a Goliathus Extended Chroma for my laptop, so I wouldn't know if it depends on the device or not.
     
  6. Xiantyl3x

    Xiantyl3x New Member

    I'm still unable to install synapse 3 and tweak my Nari ultimate, Thinking about returning them. Paid over 200 and this is crazy
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >