I present to you Firebat's Blade 15! (144hz/i7-8750H)

Discussion in 'Systems' started by Firebat246, May 24, 2018.

Thread Status:
Not open for further replies.
  1. @Firebat246 did/does your Blade's fans have a distinct high pitched whine to them or do they just make a whooshing noise without the whine?
     
  2. Firebat246

    Firebat246 The One

    New Blade has some good scores. I am pleased so far. Edit: Even better score updated
    https://www.3dmark.com/3dm/26873054?

    I have a 2tb Samsung 970 Evo coming in tomorrow... there is some driver issues if you install a fresh windows 10. I think instead I will clone the 512gb drive to the 2tb to avoid issues. My windows seems to be running fine so far.

    It has a slight whine to it but its much much less pronounced then the Blade 14.
     
    Last edited: May 31, 2018
    mrvortep, freakydoctor and Tubernator like this.
  3. labotsirc

    labotsirc Active Member

    How are the temps now?
     
  4. Are the speakers THX like the phone?
    I only ask because I couldn't find that bit advertised if it did
     
  5. Soelreaver

    Soelreaver New Member

    No they are not

    Thats the same HD i have Ready to POP in. What are you using to Clone your ssd?
     
    Last edited by a moderator: Sep 4, 2018
  6. Firebat246

    Firebat246 The One

    Paragon drive or easeus. I actually am second guessing the cloning option and may try fresh install. If I'm unhappy with it I'll just clone my 512 since I'm not wiping it.
     
  7. rb6freak

    rb6freak New Member

    You can clone or fresh install from the installed version of Windows. Just create a system image via Control Panel --> System Image Backup. Boot from the USB directly if you want to start fresh as the Razer system image recovery is loaded onto your new SSD. Boot from a Windows loadable USB or recovery USB to load the image if you want to clone. I went with the fresh image install myself. No issues, all Razer drivers and such were present upon bootup.
     
  8. Tubernator

    Tubernator New Member

    Great score! best I got was 14630. I had to RMA myself due to faulty power supply (buzzing, and inconsistent power). So of course, had to RMA everything. Support was great btw, hope to have the new RB15 early next week.
     
  9. Badgertista

    Badgertista Well-Known Member

    This … no matter the brand, I always do a fresh install

    Add the free version of Macrium Reflect to that list ;)
     
    Last edited by a moderator: Sep 4, 2018
    Thorj and OceanBluetrendfresh859 like this.
  10. Has anyone considered rolling back to Win10 1703? Any version above that makes both the Blade 14 2017 and AWA 13 R3 CPUs bounce all over the place. Temps rise and just seems to get worst. I run a pretty stripped down version on both laptops, with undervolt and Cortana uninstalled.

    Love the design of the new 15. I’m hoping the Pro version will be a similar design. If that is the case and reviews are good I’m going to pick one up.
     
  11. Firebat246

    Firebat246 The One

    Not really that easy to just roll back if you don't have a restore point with 1703. Most people are stuck on a newer version.
     
  12. I called

    Microsoft support helped roll back for me at no charge. They did this for both machines on separate occassions. Start a chat requesting to go back to 1703. Tell them your cpu clock is bouncing up and down. On both occassions they completed the process for me remotely.
     
  13. Firebat246

    Firebat246 The One

    With the same undervolt I am seeing temps about 10c less on average across the board. That is good enough for me to consider it a better machine...however I will still probably repaste with Thermal Grizzly.
     
  14. DarthVader0

    DarthVader0 Member

    That seems to be more of a major undertaking now a days.
     
  15. nc_pt

    nc_pt New Member

    When you repaste could you make a step by step picture tutorial for the newbies of the razer community? :)
     
  16. DarthVader0

    DarthVader0 Member

    Here's an older video, but you'll get some idea of the work needed


    Its not for the faint of heart and/or the inexperienced
     
    ricstar likes this.
  17. Badgertista

    Badgertista Well-Known Member

    I don't have the issue on my Blade 2017, but I did a fresh install from the updated official MS Windows 10 ISO. I can't comment on the "update" path
     
  18. labotsirc

    labotsirc Active Member

    Great news!!, if you re paste we will be happy to hear from you if they went further down.
     
  19. Shadow_Bullet

    Shadow_Bullet New Member

    I just placed an order for my Blade on Amazon (it's out of stock but whenever it comes back it will be shipped) just in case there are any issues with I can return it to Amazon and get a new one super fast. That and I wanted to get the 5% back with my Prime Card (Like $130) so that was also a significant factor. I can't wait for it to come in, I'm thinking it will be a batch 2 device so hopefully all the issues are not present with my model but time will tell.
     
  20. Firebat246

    Firebat246 The One

    Got my 2tb SSD in.. going to work on getting that up and running tonight as a fresh install and I'll let you guys know how I make out. Backup plan is to just clone my 512 drive to it. Cheers!
     
    Soelreaver likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >