Im about to give up on life, and RAZER

Discussion in 'Razer Synapse' started by csills89, Jun 18, 2018.

?

What would you do?

  1. Give up? Move companies?

    19 vote(s)
    76.0%
  2. Try the 12th time reinstalling

    3 vote(s)
    12.0%
  3. Try reinstalling windows the 5th time.

    3 vote(s)
    12.0%
Thread Status:
Not open for further replies.
  1. csills89

    csills89 New Member

    OK, well this is my last resort after being connected to a Microsoft team 5 times. and Also reinstalling windows...4 times.

    The reason I am here because I recently got a update through microsoft and it literally made it where i can not load up razer synapse 2.0. So my first impression was oh I could just add/remove it and reinstall a new one from your downloads from razer synapse. Well I am not sure if or what but this is the 11th time i reinstalled the product and i'm getting to the point where i'm gonna drop razer for good and go with a different company/mouse. I only use the damn thing for mouse 4 and 5 side buttons. That's it My mouse i almost forgot to mention is a Razer death-adder Chroma the 2018 version. I can post A PIC of what it says because i'm about to just give up. If i can't get it I'm done.

    I mean come on I reinstalled windows 5 times and 11 times on Synapse It gives me the same error everytime. I also reinstalled .net framework over and over again also running a chkdsk on my drive and a SFC /scannow.

    https://imgur.com/EBNScBM
    [​IMG]
     

    Attached Files:

    • rzr.png
      rzr.png
      File size:
      1.4 MB
      Views:
      47
  2. theconquergamer

    theconquergamer New Member

    ok i think you should uninstall it for real and report it
     
  3. Predator5

    Predator5 Well-Known Member

    When you said that you reinstalled Windows I presume you also formatted (wiped) your hard drive.

    Did you contact Razer Support? (Not Microsoft support.)
     
    ahlin941 and ricstar like this.
  4. AnnieBlack

    AnnieBlack New Member

    And I am about to give up on dissertation writing :) At least I am not going to do this by myself anymore. I'd better spend some more free time reading through this forum :)
     
    Last edited by a moderator: Jun 19, 2018
  5. csills89

    csills89 New Member

    I did, and reformatted and contacted razer and they still have yet to help me
     
  6. ahlin941

    ahlin941 Member

    Seriously, contact Razer support should be better than contact Microsoft. (At least Razer know the Synapse bug which happens to you more)
     
  7. csills89

    csills89 New Member

    I have. they havent figured it out

    Bump. anyone figure this out.
    im still having issues
     

    Attached Files:

    Last edited by a moderator: Aug 26, 2018
  8. KillStealzzz

    KillStealzzz Active Member

    My advice for now: try install Windows 7. It should help you get things back to normal. Later if you have time and Windows release a new update for Windows 10 or Microsoft/Razer support team figure it out, then you can install Windows 10.
    Windows 10 ver 1803 is a big mess right now. So many bugs and unreliable.
     
    Kenserky likes this.
  9. FiszPL

    FiszPL Well-Known Member

    Nuke the OS, install it again if possible.
     
  10. csills89

    csills89 New Member

    I have. Also tried the latest build and currently on 1709 build of win10. still the same thing..it happen ever since windows updated and im having issues installing nvidia drivers, razer synapse 2.0, and other drivers. they open sometimes and just sit in the TSKMGR
     
  11. KillStealzzz

    KillStealzzz Active Member

    have you tried windows 7 ?
    If the error persist even after reinstalling windows so many times like that, there's a high chance it's a hardware problem after all.
     
  12. csills89

    csills89 New Member

    BUMP

    few months later still having the same issue. Now steam won't open either and still having issues with razer synapse 2. I get a error of mscorlib.dll over and over again. I've reinstalled frameworks and windows 10. I even bought a new version of my deathadder to a deathadder elite
     
  13. Predator5

    Predator5 Well-Known Member

    Try placing the mscorlib.dll in the same folder where the Synapse executable is found.
     
  14. Behelith

    Behelith New Member

    Just dump Win 10, install 7, not only this but a zillion other issues will be solved.
    I tried windows 10 seven times and dumped it again and again.
    Since January 2018 they have been spawning Godzilla like bugs that annihilate compatibility with soft and hardware over complete areas of the market at once. I have had experiences many times over this year, MS dumps a functionality because it's 5 years old, suddenly 10 billion things that depended on that disintegrate on the spot. They are currently chain producing bugs and shooting them at the market with a battery of C-RAM gatling guns.
    Also I tested performance of both and win 10 is about 20% slower on all tests (CPU, mem, HDD, 2D video) except for 3D video (same performance so gales aren't that much affected).
     
  15. Stevie_Eye

    Stevie_Eye Active Member

    Um, might want to fix your title TBH... It's slightly alarming is all.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >