I'm an idiot. Please help me fix my Orbweaver. (Or laugh at my misfortune)

Discussion in 'Razer Support' started by joshredd, Dec 24, 2018.

Thread Status:
Not open for further replies.
  1. joshredd

    joshredd New Member

    UPDATE: I fixed it! I started over and spliced it again, this time taping off each pair of wires instead of wrapping them inside the same roll. Got it working! Now that I know the device still works, I'll clean up the repair job or replace the cable. For now, it's a good reminder to be careful.

    I'm a video editor and bought the Orbweaver a few days ago and have spent the last couple of days learning how to use it and getting it set up the way I like it for editing in Premiere. I LOVE this thing and was really looking forward to getting good with it. I bought it with a Huion 610pro v2 tablet to replace my mouse so my end goal was to ditch the keyboard and mouse all together except when I needed to actually type.

    I zip-tied the cables for these two peripherals (loosely) so they wouldn't flop all over my desk. Last night, after getting to a good spot with my set-up, I wanted to take the tablet home and let a friend play on it. I went to cut the zip-ties and in an instant, I realize I snipped into the cable of my brand new Orbweaver. My heart sank but the lights were still running on it and it still functioned! Shortly after though, My computer kicked it off and said the USB device was drawing too much power. Tried again, nothing. Tried not to curse (I work in a church after all) and failed. I was pissed. So I called it a night, went to DQ and ordered a large Blizzard because how can you be mad eating ice cream?

    This morning (Christmas Eve) was a new day with new possibilities. I went to the hardware store, picked up some electrical tape and watched a how-to video on splicing USB cables. It pained me to cut the cable completely but I knew there was no returning it on warranty. So I cut it and got to work on splicing. Did a great clean job of splicing and keeping the wires separate. Wrapped it up nice and neat with the tape and zip-tied the two ends of the cable together so they won't pull apart. Moment of truth - I plug it in: same message. I reset the SMC on my Mac, restart the computer, same issue. Tried different USB ports and same thing. plugged my phone into those ports and the ports still work.

    For the love, is there anything I can do to fix this thing? I at least want to know what's going on and, if it's beyond repair, what happened to it. I'm a problem solver, I need to know. Is it possible the device itself was actually damaged? I'm willing to tinker.

    TL;DR - I accidentally cut the cable on my brand new Orbweaver, spliced the cable back together, and it still doesn't work.

    Thanks for any help, condolences, laughs, or suggestions. Merry Christmas!
     

    Attached Files:

    Last edited: Dec 25, 2018
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >