Input lag with the Core + RBS + 1070 in WoW?

Discussion in 'Systems' started by Soujiro89, Jan 23, 2017.

Thread Status:
Not open for further replies.
  1. Soujiro89

    Soujiro89 New Member

    So I finally got my Core after almost a year of dealing with customs, shipping, RMA's and more customs... And it is awesome. Except in WoW.

    There is heavy input lag when playing. I've tried the following:

    -Not using the Core, my old setup = no input lag
    -Using the Core + Monitor into Core + Keyboard and Mouse into RBS + Everything else into Core = Input lag
    -Same as above, but Keyboard and Mouse into Core and Everything else into RBS = Input lag
    -EVERYTHING into the Core = Input lag
    -EVERYTHINg into the RBS (Minus Monitor) = Input lag
    -Rebooting my pc

    Also tried within WoW:

    -Disabling all addons
    -Lowering graphics
    -Maxing graphics
    -Deleting my entire WTF Folder, everything is back to default

    Since it was installed just today, all my graphics drivers are up to date, as well as BIOS and Core and everything else.
    Also I've checked other games, and they work just fine. Overwatch that is from the Blizzard family, works as expected. Rocket League on Steam works alright. Portal 2, same.

    Did anyone else experience this issues?

    Last but not least: yes, since I'm playing from Latin America I'm getting 200ms, but that's normal. In order to test this I'm using interface buttons (Escape Menu, Character Pane, etc) to test this. So it definitely doesn't have to do with latency.
     
  2. jaseow

    jaseow Active Member

    Have you enabled the option to reduce input lag ? Or disable hardware cursor ?
     
  3. Soujiro89

    Soujiro89 New Member

    I'll try that, thanks!
     
  4. Soujiro89

    Soujiro89 New Member

    Sadly, it didn't work... I'm running out of options here.
     
  5. Dallian

    Dallian New Member

    Hey, I think I can help, but you need to isolate the case first by starting with the setup with no input lag.
    So 1) The "Not using the Core, my old setup" situation.
    then, 2) Just using the Razer Blade Stealth + Mouse.
    then, 3) Razer Blade Steath + Mouse + Keyboard.
    then, 4) Razer Blade Steath + Mouse + Keyboard + Core + Monitor.

    Then, if it doesn't work, try with new cables and repeat the process. (sometimes, the USB-C gets a little bit wiggly) I'll be waiting for your feedback. I have other protocols to make you try but first we need to establish a baseline.

    Good Luck!
     
  6. Soujiro89

    Soujiro89 New Member

    Apparently it had to do with the GeForce Experience thingy that was messing up my keyboard. If anyone has this issue, try disabling it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >