Is there any way to hard reset my Mamba 2012?

Discussion in 'General Discussion' started by ment2008, Feb 1, 2016.

Thread Status:
Not open for further replies.
  1. lifethinkAshGrey266

    lifethinkAshGrey266 New Member

    Hi guys,

    i purchased on the 31 Dec 2015 a new Razer Mamba 2012, but today after purchase a new Blackwidow expert and restart my PC my Mamba mouse completely stopped to work and:

    i tried everything,
    Remove battery > Plug back > checked with fluke and the battery is ok.
    Turned On & off
    Give it like 24h ON mode > Recharged on OFF mode > nothing.

    i think the only solution left is to hard reset it somehow because it bricked atm...
    how im doing that or what else i left to do?

    [​IMG]
     
    Last edited: Feb 4, 2016
  2. IDKFA99

    IDKFA99 New Member

    Hmm, I have my mamba somewhere hidden with exactly the same issue, I would like to know the solution as well
     
  3. APATITEXanadutech438

    APATITEXanadutech438 Active Member

    hmm can i reset my keyboard too? one key is not functioning...that may be hardware problem though, hoping it's bugged software somehow =(
     
  4. WISHMASTER_BURBERRY

    WISHMASTER_BURBERRY Active Member

    You guys can't hard reset a Razer device, it doesn't have on-board memory but you can to sleep tho. If want reset tho, just change your email that's used by your Synapse account.
     
  5. lifethinkAshGrey266

    lifethinkAshGrey266 New Member

    Well should be some way to repair it or something, after all its 2 months mouse... and not from cheap model..
     
  6. lifethinkAshGrey266

    lifethinkAshGrey266 New Member

    Bump???????????
     
  7. jaseow

    jaseow Active Member

    Reposting without link cos its been 5 days waiting for moderator approval.

    I recently had my Razer Mamba 2012 suddenly stop working on me as well (everytime I clicked the mouse it would freeze for 3-5 seconds and I would hear the sound of a new device being connected once it unfroze)

    I downloaded this : (go google razer mamba firmware update and its the softpedia link for 1.07)

    and followed the steps and it worked fine again after that.

    One thing to note though, the firmware updater updated the firmware for the mouse fine, but when trying to update the firmware for the dock it would not start (stuck at 0%). If that happens to you press the wireless button on the dock before connecting the cable and it should enter bootloader mode and update the firmware without problems.

    If the mouse wont update you can put it in bootloader mode as well by holding down the right & left mouse button down before plugging in the cable(not 100% sure cant remember if it was just left & right buttons or scroll wheel as well)

    Hopefully that helps you. Cheers !
     
    milan.djolle likes this.
  8. lifethinkAshGrey266

    lifethinkAshGrey266 New Member

    Thank you so much for the reply, i was hoping that some of Razer staff will help here, but i guess they don't really care.

    I found the download link and downloaded, but i think the issue is not about firmware update, my mouse does not turn on (no lights on it). only mouse duck is working, nothing else so i receive :
    [​IMG]
     
  9. IDKFA99

    IDKFA99 New Member

    Razer should compensate you.
     
  10. lifethinkAshGrey266

    lifethinkAshGrey266 New Member

    I don't think they should, im as a fan of Razer brand will never touch anything with Razer sticker on.
     
  11. boAgie_f

    boAgie_f Member

    @IDKFA99 ... this is low chance,but is possible!
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >