Kraken Pro 7.1 V2 Popping Sounds

Discussion in 'Razer Support' started by emmablythe, Jul 18, 2018.

Thread Status:
Not open for further replies.
  1. emmablythe

    emmablythe New Member

    Hi all, I have a Kraken Pro 7.1 V2 headset. I am using Windows 10, all drivers updated, all synapse drivers for my headset are up to date. I have only had this headset for a few months.
    My Problem: I will hear a 'popping' noise in my headset and audio will cut out completely for 3-4 seconds, and then resume to normal. This problem is very sporadic, sometimes it will happens 3 times in one minute or once every hour. I have tried wiggling the cord as suggested here . switching ports, restarting computer, checking for any malware that might mess with my USB, adjusting the slack the wire has, updating all of my drivers, and scouring online for a solution. This problem has made online/multiplayer gaming a big no-no for me as I can't hear my teams comms or whats even going on in the game. It is not an application issue, I have sat at my computer with no applications running and it will still 'pop' and 'restart' frequently. I am at a loss and a little disappointed, since I paid a lot of money for this and already encountering serious and frequent audio issues with less than a year of use.
    So what do I do? I have a warranty from Best Buy, should I get a replacement and just pray this doesn't happen again? Do I need to wiggle the wire more? Please help!
     
  2. FirePenguin

    FirePenguin Well-Known Member

    Hey! Have you tried using it on a different PC? If it still does the same thing, I would suggest getting it replaced since it would be a hardware issue.
     
    freakydoctor likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >