Kraken TE does not have proper sound in THX and Game

Discussion in 'Razer Support' started by BrickBadWolf, Aug 29, 2019.

Thread Status:
Not open for further replies.
  1. BrickBadWolf

    BrickBadWolf New Member

    Hi there

    I have a problem where the Kraken TE is very quiet for some reason. This strangely, does not happen in Chat, only if I choose THX Spatial or Game in the choices of audio output.

    I have tried the following solutions but none of them have helped so far:

    • reinstalled Synapse 3 a gazillion times
    • changed settings in Synapse
    • changed settings in Windows Sound controls (use this as main etc.)
    • activate/deactivate THX service
    • Firmware update with link provided from Razer's website
    • Updated through device manager
    • Rolled back to old drivers
    Strangely, Game and THX are the ones that don't work properly and happen to be listed as speakers instead of headphones. Chat, which is the working one is correctly listed as headphone.

    Unfortunately I haven't found any option in the Windows controls where it let's me choose the type of output device.

    Does anyone have a tip for me? While Chat is ok to use, the quality in Game/Spatial is so much better but it is so quiet that I don't understand a single thing. I have looked through several articles and forum posts but haven't found a solution yet.

    The headphones are plugged into the USB controller and I have tried other USB ports.

    Specs:

    Windows 10 Home
    AMD FX(tm) 8320 3.5GHz
    HyperX FURY DDR3 2x8GB
    Gigabyte GTX-750 Ti Windforce 2X 2GB GDDR5
    AsRock 970M Pro3
    Corsair VS550

    Kind regards
    Wolf
     
  2. BrickBadWolf

    BrickBadWolf New Member

    bumping this so hopefully a team member can finally take care of this
     
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! Thanks for posting your concern here. Please launch your Razer Synapse 3.0 check if your Razer Kraken TE - Game is selected as the default device. Also, ensure "Kraken TE-Game" is set as the default device in Sound Properties > Playback as per below steps. Lastly, check that Game/Chat balance on USB dongle hardware is set to mid.
     
  4. BrickBadWolf

    BrickBadWolf New Member

    There was an automatic update today and now it seems to work. I do however hear crackling a lot which wasn't there when it was all quiet.
     
  5. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for letting me know. Does that the crackling happen to all application with audio? Have you tried tweaking/adjusting your equalizer? Please adjust your 2kHz down to -12db and see if the cracking stops.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >