Late 2019 Stealth... Anyone chime in on linux support?

Discussion in 'The Linux Corner' started by Sumarious, Jan 17, 2020.

Thread Status:
Not open for further replies.
  1. Sumarious

    Sumarious New Member

    So... I got the new late 2019 stealth.

    I use it almost exclusively for work because of it's awesome battery life, that is when i disable the NVidia GPU and put it into low power mode... lol

    But most of the work I do on location is in a terminal, and I thought.. Meh.. May as well try and boot into Linux and see how it responds.

    Touchpad.. A no go right off the bat. I had to go find a USB mouse.
    Wifi was off the table too.
    Plugin that USB C Ethernet adapter... Luckily it was supported.

    So I managed to get the hardware driver window open and see that it had drivers for both the NVidia card and the intel card..

    So.. Now I'm tempted.

    Does anyone have any experience with this device?
    I'm most likely going to be going with mint if I do.

    Anyone able to offer any feedback or advice before I trash my Windows Home install...
    *mumbles something under his breath about a GD 2k$ laptop that don't even ship with Win 10 Pro..*
  2. Panaman

    Panaman New Member

    I am also interested in this. Need a laptop upgrade and Linux support is a MUST. I really wish Razer official actually cared...... like the CEO said they would.....

    Does the Mercury White edition with no Nvidia work any better, as that's the one i'm looking at currently.
  3. brettlandau

    brettlandau New Member

    I have the GTX edition late 2019 model and have been running Ubuntu Budgie 19.10 for about a week now. Everything works well except for one pretty significant issue: Waking from sleep is problematic.
    I haven't been able to completely solve this issue but sometimes after opening the lid, the machine will freeze and to get out of this state you must close the lid, wait for it to sleep again, and then re-open the lid. This is not a big deal, EXCEPT that sometimes on the second wake from sleep, the screen begins to flicker. Now, to get rid of the flicker the only thing I know that works is booting back into Windows, entering Safe Mode, and then the flickering is gone. Seems to be some issue with the graphics drivers, but I'm not totally sure.
    angelfire0317 likes this.
  4. Panaman

    Panaman New Member

    Linux kernel 5.6 just got a lid quirk added to stealth late 2019.
    see this article
    jerume, angelfire0317 and brettlandau like this.
  5. brettlandau

    brettlandau New Member

    Interesting! Any idea when the new kernel will be released?

    Would it also be possible to apply this patch manually until then?
  6. Panaman

    Panaman New Member

    5.5 JUST released, so 5.6 wont be out for 2.5-ish months.
    Not sure if you could patch it manually. They might backport some of it to 5.5 so fingers crossed.
  7. benjamin.lefaudeux

    benjamin.lefaudeux New Member

    razer blade stealth pure Intel here (ice lake graphics), pretty good I would say. Tested Fedora, Ubuntu 19.10 and Clear Linux.

    What does not work;
    - The lid handling is broken as mentioned above, in that closing the lid will not put the computer to sleep and opening it up will not awake the computer (except for some random combinations, like if the computer goes to sleep on its own). This is in my opinion a gross oversight from Razer, it's not as if lid support was something new, they just broke something which worked. It will get fixed eventually, but seriously Razer people...
    - The screen is sometimes a bit 'patterned' with this HW, I think that it comes from the Intel graphics drivers being slightly buggy and some options (like panel self refresh, to save battery life) being activated. Just a guess, but it disappears after a while

    What works;
    - pretty much everything else. Wifi, bluetooth, touchpad (even great multi touch on fedora with libinput-gestures and the extended gestures gnome extension)
    - great battery life, something like 8-9 hours
    - no fans, really. You can hear them when hammering on 8 threads, but that's pretty much it. Great thermals in general
    - keyboard lighting with openrazer
    Panaman likes this.
  8. Panaman

    Panaman New Member

    Still looking at options for new Linux laptop. Would you be willing to revisit this thread once 5.6 comes out? would really help with my decision.
  9. benjamin.lefaudeux

    benjamin.lefaudeux New Member

    yes sure, I'll keep that in mind. On Clear Linux right now, so should be one of the firsts on 5.6, but still some time to go. I was considering the new Dell XPS 13 dev edition before buying this one, all other options were not half as good as far as I'm concerned (in case it helps).
    Panaman likes this.
  10. gtorres88

    gtorres88 New Member

    I have the mercury white version and installed fedora 31 on it. I've only had it a couple of days, so I don't have a full picture yet.

    Most things work fine, including hot-plugging an eGPU on wayland, but sometimes unplugging it causes the machine to crash, not sure whats going on yet. There's also an additional problem in that the eGPU is never picked as the primary GPU so you get a degraded experience on an external screen. What this means is that even though the eGPU is doing a lot of the processing, the egpu has to copy a buffer back into the igpu and then back out to the egpu for display. It results in a 30fps experience in gnome shell and pretty terrible gaming performance. There's some patches and workarounds for this, but no clean solution yet.

    The other issue i've noticed is the lid open problem that you guys have described. It just looks like to me like the laptop never comes back from sleep. When I was debugging this I noticed that "LID0" is not in /proc/acpi/wakeup, so I assumed this was a DSDT/ACPI issue. If it is indeed this suspend loop problem, I can try the new kernel or this fix from the Arch guys:

    I will try tonight and report back.

    Audio, Wifi, trackpad all work fine, including gestures. I have not messed with keyboard lighting and probably won't. I haven't tested bluetooth but will also do that.
    Panaman likes this.
  11. gtorres88

    gtorres88 New Member

    Well, I installed the latest kernel and also tried the arch fix and neither worked. This feels like the ACPI issue to me since LID0 should technically show up.
  12. Panaman

    Panaman New Member

    Thank you so much for the information. I really wish Razer meant it when they said they wanted to support Linux.......
  13. gtorres88

    gtorres88 New Member


    I reinstalled fedora 31 and managed to replicate the suspend loop issue. Turns out I was seeing something different related to some update that keeps the system from completing suspend. Trying to narrow that down.
    Panaman likes this.
  14. benjamin.lefaudeux

    benjamin.lefaudeux New Member

    hey there, I finally switched to Manjaro and am now using 5.6 rc4. The lid closure/sleep finally works out of the box, and frankly it's more stable with this kernel than with previous LTS (5.4), so I would definitely recommend the jump. I think that Razer f*cked up in that case, I bought this one (all Intel) over other laptops because I expected good Linux support but did not expect an own goal. If it was not clear already, do not buy it expecting better than average OSS, this is not happening.
    After a couple of weeks with it, I still stand buy my earlier post though, the build is very good, thermals and battery are top notch, it's a real shame that the screen is not taller but other than that the hardware is almost perfect for my taste. Doing ML, IceLake is also a very good surprise, a lot faster than a desktop Skylake using PyTorch, the recent mkl-dnn do wonders. I've a recent MBP 15 i9 from work, the cpu is not half as good.
  15. Panaman

    Panaman New Member

    Thank you so much for the follow up. Very helpful. Yeah... Razer fucked up a lot of things... Crazy to think that in 2020 they cant get a lid switch to work correctly lol.

    "Better than average OSS support" is not something I expected from Razer. Im just happy It works at all.
  16. maxiecaulfield

    maxiecaulfield New Member

    Reporting in with my experience on the Iris Plus Mercury White model.

    When I first got it in December, I tried to use Arch on it, but had issues with graphical corruption (flickering at the top of the screen & Electron apps not refreshing) and failure to resume from sleep.

    I tried Arch again with kernel 5.6-rc7 now that the sleep workaround is merged, and it's working great! Sleep works perfectly, and it seems Intel worked out the graphics issues. I'm using Xorg with modesetting (as opposed to xf86-video-intel), fwiw.

    All of the hardware works out of the box: wifi, bluetooth, touchpad, audio, Fn key shortcuts, webcam, etc.
    Last edited: Mar 26, 2020
    riwenna and Panaman like this.
  17. Panaman

    Panaman New Member

    Thank you for this report. I appreciate it!
  18. With the official kernel 5.6 release, does your wifi card still work. Mine is fine with 5.5 but cannot connect when going to 5.6
  19. benjamin.lefaudeux

    benjamin.lefaudeux New Member

    Manjaro 5.6.4 here, wifi is ok but lid to sleep is broken again. At this point I would not recomend this laptop for Linux unfortunately, no suspend + no firmware update are two pretty big pills to swallow (there are working solutions for these "problems" in other OEMs, razer just put itself in a broken corner on that one).

    Premium laptops, the company communicated on linux support but did nothing that I know of to follow suit, not quite worth it. Shame, because some other aspects are really good IMO (thermals, build, battery life are MBP class)
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >