Latest update seems to have broken 3.0

Discussion in 'Razer Synapse 3 Beta' started by KeenJin, Apr 2, 2019.

  1. KeenJin

    KeenJin New Member

    With the update, synapse 3.0 won't start.
    updatefucked3.0.png
    All it tells me is that it failed to start and retry.

    I have tried restarting synapse, restarting windows, reinstalling synapse.

    My windows 10 is updated, just FYI.

    3.0 seems to be way damn too buggy even considering that it is on beta.

    Wish synapse 2.0 supported the newer devices. :slightly_sad: -had to install 3.0 with my new naga trinity

    Before the latest update that broke my 3.0, 3.0 sorta worked.

    But the calibration was very off compared to synapse 2.0.

    Not to mention disappearing calibration setting -except the lift-off range one, which doesn't really work either- under calibration tab. :/
    whatisee.png
    I have sent tickets about it, all they gave me was the basics, reconnect, reinstall, reboot yadayadayada.

    The only way to work around that calibration problem was to reinstall windows completely -and the same problem occurs right as I restart my computer. lmfao
     
    spikeyshrek likes this.
  2. spikeyshrek

    spikeyshrek New Member

    I have had the exact same issue, spoke to support and they were bloody useless and couldn't fix it. It is ridiculous that Razer's new devices are supported only on a beta of all things, stupid business decision. I haven't been able to use my new Razer keyboard with 3.0 since I got it several months ago. I certainly will not be buying anything else Razer wise until synapse 3 is out of beta and works.
     
  3. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    Hi everyone! If you are still having the same issues with your Razer Synapse app, please send us a PM together with the exact details of your issue. Kindly include the Synapse Logs (To get the Synapse logs, download the installer here). Provide us the link where we can get the logs. You can upload the files on your cloud-storage site and we will just download it.

    Make sure to include the link of this thread. We'll be waiting.

    *To send a PM, click on my profile picture and select Start a Conversation.
    *Moving thread to Support Forum for visibility.
     
  4. spikeyshrek

    spikeyshrek New Member

    Already done all that mate with the previous tech support person, you already have my dxlogs, synapse logs and msinfo logs.
     
  5. cm0918

    cm0918 New Member

    Last edited: Apr 4, 2019
  6. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    That would do. Please do send me a PM so that I can assist you further.
     
  7. Kamuix56

    Kamuix56 New Member

  8. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    Have you tried to uninstall and reinstall the Razer Synapse app on your computer? If you still do having the same issue, can you send us a screenshot of your app? Send it through PM and make sure to add the link of this thread. I'll be waiting there.
     
  9. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >