Linux on a new blade

Discussion in 'Systems' started by _ramsey_, Feb 4, 2015.

Thread Status:
Not open for further replies.
  1. carlrice

    carlrice New Member

    Figured I'd chime in with my experience. Did a ton of research before buying, overall looked promising. I have put Linux on just about every machine I get my hands on and I have to say that this has been one of the easiest. I am using Blade 2015 QHD+ 16gb 512gb.

    Here is what I did:
    • Install Ubuntu 15.04 "side by side" with Windows, half and half space wise
    • Install Linux 4.0.5 kernel
    • Apply touchpad fixes from Alex Cabal
    • Install bumblebee to save battery
    • Apply battery scripts from Zhe Hou's blogspot (excluding the kb/touchpad because when it powers down its annoying to wake up)
    • Apply a fix for repeat sleep every ~30s after first sleep launchpad bug #1450013
    • Set resolution to 1920x1080 for desktop and plymouth since HiDPI is a non-starter IMHO
    • Set resolution in grub to 1600x1200 (not the best, but at least I can read it)
    Getting about 4hrs browsing, setting up, configuring, etc. Using it as an Android development machine. Builds are fast, machine is slick, can dual boot to game. Can't complain!

    Now this might seem like a lot of steps but anyone who's dealt with oddball laptops and Linux can attest, this ain't bad at all.
  2. SuperEvenSteven

    SuperEvenSteven New Member

    I went down a similar path recently with setting up my razer blade laptop too. I'm still looking for a DSDT fix for the lid status. Here's a guide I made up for my own reference if anyone is interested :

  3. buzzPinkdirect588

    buzzPinkdirect588 New Member

    Anyone experiencing microphone issues? Mine doesn't work after going through all the steps from the tutorial in the previous post.
  4. _ramsey_

    _ramsey_ Active Member

    I have odd behavior related to the headphone/mic jack. Frequently I will boot up with the earbuds plugged in and it's like ubuntu doesn't see it is there. So I'll hit youtube or something and sound comes out the speakers instead of earbuds. If I unplug and plug them back in, the problem basically resolves itself.
  5. Malevolence23

    Malevolence23 Active Member

    I've sideloaded ubuntu onto my 2012 Blade and it works fine. I have the same issue with the trackpad but I haven't been really concerned about it. Since I'm seeing people have fixed it I might look into it.
  6. _ramsey_

    _ramsey_ Active Member

    I'm just now noticing that the webcam doesn't seem to work properly. If I start cheese, I get a few partial frames of video before it fails with the message "There was an error playing video from the webcam"

    $ cheese
    libv4l2: error got 4 consecutive frame decode errors, last error: v4l-convert: libjpeg error: End Of Image
    (cheese:8048): cheese-WARNING **: Failed to allocate a buffer: gstv4l2src.c(749): gst_v4l2src_create (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin18/GstV4l2Src:video_source
    lsusb shows me the device

    Bus 003 Device 005: ID 0bda:579f Realtek Semiconductor Corp.
    and it appears to be a UVC device

    $ lsusb -d 0bda:579f -v | grep UVC
    Couldn't open device, some information will be missing
      bcdUVC  1.00
    running guvcview gives me a segmentation fault
  7. illathon

    illathon New Member

    One thing I want to know is if it supports vt-d and iommu ... If that is the case you can have your cake and eat it too. This would give you almost native performance with Windows virtualized with KVM. I looked in the bios but it gives no cpu options.
  8. _ramsey_

    _ramsey_ Active Member

    I've finally installed 15.04 and a 4.x kernel. Some observations: The trackpad works on the 4.0 kernel. No patch needed. The webcam still doesn't work. Using full disk encryption, once I updated from 3.19 to 4.0 (or 4.1, I've tried both) the laptop keyboard doesn't work during the disk unlock at boot time. In order to type in the password to the disk, I have to break out ol' clackity the USB keyboard. Once the disk is unlocked and it finishes boot, the laptop keyboard works again. I tried the NVidia 352 driver first (on the 4.1 kernel). Still get the black screen on boot. The mouse cursor disappearing on the top edge of the screen was fixed, but the screen would blink out and sleep the laptop around once a minute. Since that wasn't usable, I'm trying again with a reinstall. Maybe 355 this time.

    Screen blacks out every ~30sec or so. When I dmesg I see

    vgaarb: this pci device is not a vga device

    This is on 355-dev driver with the 4.0 kernel

    After trying 352, 355, and 346 on 15.04 and getting the screen sleep after ~30sec, I dropped back to ubuntu 14.04.3. I just installed 355 on it and for the first time ever, I did not get the black screen on login. Sweet. Now on to see if I can fix the mouse on this kernel version :)

    Using ubuntu 14.04.3. The xorg-edgers 355 nvidia driver package is working perfectly. To fix the mouse, I installed the vivid 4.0 kernel here:

    Download the generic amd64.deb files and the all.deb file.

    sudo dpkg -i *.deb

    in the directory where they are downloaded. Then edit /etc/initramfs-tools/modules and add hid_rmi to the end of the file. Finally run update-initramfs. Something like

    sudo echo "hid_rmi" >> /etc/initramfs-tools/modules
    sudo update-initramfs -u

    Now restart. The last two lines here are necessary if you want to use full disk encryption. If this isn't done, then when you get to the password prompt to unlock the disk, the keyboard will not work.

    Oh, and note to self, to verify the checksums file, you need to get the gpg key to do that with

    gpg --keyserver --recv-keys 0x17C622B0
    gpg --verify CHECKSUMS.gpg CHECKSUMS

    So you know no one tampered with the kernel before installing it. Finding this info was not as easy as it should be.

    It turns out my webcam works fine with luvcview. It's just not working with cheese, or firefox :-/
    Last edited by a moderator: Aug 25, 2015
    Goddard likes this.
  9. buzzPinkdirect588

    buzzPinkdirect588 New Member

    There's one more thing that I noticed. Every time I would load Ubuntu, for some reason the internal microphone doesn't get detected. So I can't use any video chat. But then for some reason the microphone just starts working randomly after a while -- no idea why. It's the same behavior on any 4+ kernel. Do you guys experience the same?
  10. _ramsey_

    _ramsey_ Active Member

    Oh, internal mic. I haven't even tried that. I always use the mic on my ear buds. Just checking the input tab in sound settings, the internal mic seems to be working. 14.04.3 and 4.0 kernel at the moment.

    I've found I can get cheese to work with the webcam if I go into cheese preferences and change it to use photo/video resolution of 1280x720. Using other resolutions listed do not appear to work.
    Last edited by a moderator: Aug 25, 2015
  11. illathon

    illathon New Member

    With doing this method where you able to switch between your Nvidia and Intel gpus?

    For some reason I can't.
  12. _ramsey_

    _ramsey_ Active Member

    Yeah, no problem.

    $sudo prime-select intel
    log out
    log in
    $prime-select query
    $glxinfo | grep OpenGL
    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
    OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.5.9
    OpenGL core profile shading language version string: 3.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 10.5.9
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    Goddard likes this.
  13. illathon

    illathon New Member

    For some odd reason I didn't have GLX in my Xorg log.

    glxinfo does nothing.

    Why wasn't this installed by the nvidia driver, or ubutnu before hand? any ideas?
  14. _ramsey_

    _ramsey_ Active Member

    I think glxinfo is supposed to be installed with mesa-utils

    Time to try Wily :) Unfortunately, making a USB stick with startup disk creator in 14.04 and then testing it tells me

    gfxboot.c32 not a com32r image

    Seems I ran into this before. Tried to boot the stick. Won't boot. Okay. Will try again with unetbootin.

    Webcam still doesn't work in cheese on 15.10 :/
    Last edited by a moderator: Aug 13, 2016
  15. Hey,

    Just got a new 2015 razer blade. And im not having any luck with the nvidia drivers. I either get the black screen on reboot. Or the prime select doesn't work at all. Ive read through all of this posting but, not getting anywhere. Any tips tricks places to start looking?

    Gnome Ubuntu 14.04

    zappy:~$ prime-select query
    zappy:~$ sudo prime-select intel
    Error: alternatives are not set up properly
    Error: intel mode can't be enabled

    glxinfo | grep render
    direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
  16. _ramsey_

    _ramsey_ Active Member

    That looks like what I would see after an install of the drivers, but before a reboot.

    If you haven't done all this already...

    When you reboot and get the black screen, try closing your lid until the laptop sleeps. Then when it sleeps reopen, press a key, and wake it. That would always bring the screen back for me.

    After a reboot, try prime-select again.
  17. Hozimina

    Hozimina Member

    linux on a blade is equal to skynet
  18. _ramsey_

    _ramsey_ Active Member

    So I just installed NVidia 352.63 drivers using the Ubuntu additional drivers thing. And it worked :) No black screens. No problems. The mouse just works on Wily. And I can get CUDA 6.5 doing

    sudo apt-get install nvidia-cuda-toolkit nvidia-nsight

    This is so ridiculously easy now. The only thing that really sucks to me now is the lack of a working web cam.
  19. q111v

    q111v New Member

    Thanks a lot for your detailed report, I am another CUDA-developer considering to buy a razer.

    One question though; what are the differences between logging in with Intel or the GTX? Can you still execute CUDA code (or any other calculations) on the GPU when running on Intel graphics? Is there a big difference in performance for non-graphics intense work? The low battery live worries me a bit ...
  20. _ramsey_

    _ramsey_ Active Member

    Using the CUDA installed directly in Ubuntu 15.10, I get CUDA 6.5. With that I seem to be required to log in using Intel graphics to execute CUDA code. I still haven't gotten my Homework 1 from the udacity cuda course working again with that yet though. I should probably go back and install latest CUDA from Nvidia as that seemed to work better.

    The battery life probably isn't so bad. I simply haven't fooled with the Ubuntu power settings to make it last longer. I looked at

    and installed powertop to play around with it. Setting everything to max battery savings disabled my keyboard :D I haven't tried the suggested settings or using XFCE yet. I know XFCE is lighter, but I prefer Unity over it.
    Goddard likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >