Linux on a new blade

Discussion in 'Systems' started by _ramsey_, Feb 4, 2015.

Thread Status:
Not open for further replies.
  1. jcecil

    jcecil New Member

    Quick question, why did you setup a swap space of 33GB? I thought it was recommended to set it equal to the amount of ram (16GB).

    Thanks for this information! I haven't received my blade yet, but this will be very helpful.
     
  2. Her0Zer0

    Her0Zer0 Member

    So it depends on your use case - few people are even going to go over 16 GB of RAM, let alone an additional 16 GB of swap. However, you want to make sure you allocate a little bit more than 16 GB because some binary size rounding happens and if the swap is at all less than RAM, you won't be able to suspend.

    In my case, I have some really intensive distributed memcache architecture I work on, so I want a lot of extra swap - especially when it's as fast as the 950 Pro. But you could easily do 17 GB swap and have no problem with suspend
     
    jcecil likes this.
  3. So these were two major issues I ran in to when installing and booting ubuntu.

    To fix the Display issue, either low graphics mode, or setting the Boot argument -linux nomodeset.
    Apparently some crap with the noveau driver makes this one happen.
    For reference
    http://ubuntuforums.org/showthread.php?t=1613132

    But essentially, you need to hit E at grub screen and add the word nomodeset to the end of the line that starts with linux. (This is a one time boot option, the post above describes how to set it in grub permanently, but once ytou install the official nvidia drivers, you'll be good to go, so I wouldn't advise permanently.)

    As for the Cryptswap thing. It's related to this bug here.
    https://bugs.launchpad.net/ubuntu/+source/ecryptfs-utils/+bug/1447282/comments/75

    I'm linking directly to that comment because it also has the solution to get around it. Apparently the ecryptfs has a bad regex that doesn't look for the nvme devices that the Razer uses. (Possibly your Samsung as well EverBot.)

    The solution here is to (stealing from the Bug Comment - Full credit to Ben on launchpad)

    "Find out what partition your swap is on, look in /etc/fstab and it says where it was during installation, for me this was /dev/nvme0n1p7.
    Set the no-auto flag on this partition with: fsdisk --part-attrs /dev/nvme0n1 7 "63"
    Reboot to no prompt."
     
  4. Her0Zer0

    Her0Zer0 Member

    Well this isn't really a fix if you actually intend to use the swap - for example to suspend your laptop. You could also unencrypt swap but that creates a security hole that sort of negates having an encrypted partition at all.

    I followed this guide to make it use a static password that only needs to be unlocked at boot. It also allows for hibernate mode.

    https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

    On a side note, I'm really impressed with how well this works on the latest mainline kernel version 4.6rc7. No extra patches needed - everything works, including touchscreen. Nvidia drivers still suck with tearing on video, but the low power Intel is perfect and use the less-than-ideal nvidia-prime to switch between. With logo off, half brightness, Intel graphics and lowest backlighting on keyboard and powersave mode on with cpuindicator, I'm getting 5 hrs of battery life. CUDA works right off apt - though haven't fired up anything fun yet. And even Steam works, though I haven't tried anything beyond Battle Stick which is not exactly graphics heavy but perfect for my intermittent needs.

    With the exception of the slightly mushy keys, this laptop is really a killer workhorse for me - coding in Linux, multimedia editing in Windows. Better battery would be nice but the form factor is pretty perfect and wouldn't want to change that.

     
  5. leafoflegend

    leafoflegend New Member

    So, two questions here:

    Why are you booting with UEFI disabled, and was upgrading to Windows 10 Pro necessary?
     
  6. Her0Zer0

    Her0Zer0 Member

    In the past, GRUB didn't play well with UEFI and usually required disabling it, at least for the install. But Ubuntu 16.04 is compatible with UEFI. I would still probably do it and then re-enable after install.

    You don't need to upgrade to Windows 10 Pro to get this setup working - the USB boot drive option is right in the start menu. I did the upgrade because I wanted the BitLocker encryption feature
     
  7. leafoflegend

    leafoflegend New Member

    So, I was curious if anyone here has gotten in the integrated Intel 530 Graphics to work? It just seems like Nvidia is going to eat battery up. I found a sketchy-ish discussion claiming that Mint 17.3 Rosa got it to work. As a few people have said, I want Linux for work, and Windows for play - so don't mind the lack of Nvidia support Mint offers.

    Source in question: https://askubuntu.com/questions/698168/cant-get-intel-hd-graphics-530-skylake-i7-6700-to-work

    But would love to hear if people have gotten results in Ubuntu 16.04
     
  8. Her0Zer0

    Her0Zer0 Member

    Of course - and you can even easily switch between nvidia and Intel with the nvidia-prime package. In fact, the nvidia driver has been broken for some time and causes tearing when watching videos, but the Intel GPU works flawlessly at this - with far less power consumed. You just have to make sure to install the latest mainline kernel and get the latest nvidia drivers.

    Paste the below into a file, make it executable and run it with sudo. This includes the latest mainline kernel, nvidia driver and prime-indicator Unity applet to easily switch between intel and nvidia. But you'll need to look back a few posts to see how I described what needs to be done just to get things working from the start. The default noveau driver is hosed and doesn't work, so you have to drop to a shell, replace the broken wifi firmware binaries, connect wifi via command line, update via apt, remove the noveau and install latest nvidia drivers.

    Code:
    cd /tmp
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-rc7-wily/linux-headers-4.6.0-040600rc7-generic_4.6.0-040600rc7.201605081830_amd64.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-rc7-wily/linux-headers-4.6.0-040600rc7_4.6.0-040600rc7.201605081830_all.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-rc7-wily/linux-image-4.6.0-040600rc7-generic_4.6.0-040600rc7.201605081830_amd64.deb
    sudo dpkg -i linux-headers-4.6*.deb linux-image-4.6*.deb
    sudo add-apt-repository -y ppa:nilarimogard/webupd8
    sudo apt-get update
    sudo apt-get install -y nvidia-367 nvidia-prime prime-indicator
    
     
    Last edited: Jul 6, 2016
  9. Her0Zer0

    Her0Zer0 Member

    Another update:

    A TB3 to DVI adapter + DVI cable seems to work for an external monitor. However, the nvidia drivers seems to limit the resolution options to 3840x2160 or 1980x1020 and lower res. No only does the max resolution cause my monitor to display "Out of Range" ( and despite my desktop GTX 970 having a bigger range of resolutions available) but nothing in the 2K range either - leaving with only 1980x1020. I'll have to see about that but had no problem working with both laptop and monitor or just monitor despite the hobbled monitor resolution. Had some pretty weird issues with the laptop HDMI port - screen kept dying on the monitor as if it was chocked on bandwidth despite the standard HD resolution. The nvidia drivers for Ubuntu arent great but am wondering if that port even works as others have had this issue in windows - and even the intel driver seems to have problems as well. Then again, this is latest rev of the 4.6 kernel which I believe is the only one to fully support the Intel chip and could be buggy as well. Will stick with TB3 to DP + DP cable regardless.
     
    Last edited: Jul 9, 2016
  10. leafoflegend

    leafoflegend New Member

    So my update, is I got everything working except the Nvidia driver as I would like it. Installing 364 basically broke the entire setup - lead to login loop, black screen unless nomodeset, and flickering. I purged Nvidia from my system and it works at full resolution. I have wi-fi, bluetooth, touch-screen, video streaming, etc (the essentials).

    The only problems I am left with are suspend and attempting to change resolution (down from our native semi-4k) - both lead to blackscreen. I plan to do some more experimenting, but I thought I'd let people know since there isn't a ton of info out there on this particular setup. I will be trying to get nvidia 367 with settings and prime to work with my setup solely so I can conserve battery life and solve those two blackscreen issues.

    It is a perfectly great development environment already however.
     
  11. Her0Zer0

    Her0Zer0 Member

    Strange, though I've had it go ape messing with different combinations. While 16.04 supposedly works with UEFI, the one time I left it on while upgrading, it didn't work - so I suggest disabling while trying and then re-enabling after it's confirmed working. Additionally, I suggest dropping to a shell, stopping the display manager (sudo service lightdm stop), purging all of nvidia*, ubuntu-desktop and unity, then installing all of them - have had issues even with the Unity Software Updater. This should all be done using the latest 4.6rc7 mainline kernel.

    I don't think anyone has gotten suspend on lid close to work. For me, it suspends and even comes back when opened up - but will go back into suspend after a few seconds and loop like that. Most have disabled suspend on lid close and just use the power button which works - assuming you're on the same 4.6rc7 kernel.
     
  12. Has anyone figured out the suspend problem?
    I upgraded my kernel to 4.6.2 and suspend on close lid still does not work.
    I also tried to disable suspend on close lid but it does not really work.

    Anyone give me some pointers?

    Thanks a lot.
     
  13. funbestCoral612

    funbestCoral612 New Member

    I just installed 4.6.2 from mainline ppa and it worked.

    http://kernel.ubuntu.com/~kernel-ppa/mainline/

    cd /tmp
    wget \
    kernel.ubuntu.com/~kernel-ppa/mainline/v4.6.2-yakkety/linux-headers-4.6.2-040602_4.6.2-040602.201606100516_all.deb \
    kernel.ubuntu.com/~kernel-ppa/mainline/v4.6.2-yakkety/linux-headers-4.6.2-040602-generic_4.6.2-040602.201606100516_amd64.deb \
    kernel.ubuntu.com/~kernel-ppa/mainline/v4.6.2-yakkety/linux-image-4.6.2-040602-generic_4.6.2-040602.201606100516_amd64.deb

    sudo dpkg -i linux-headers-4.6*.deb linux-image-4.6*.deb
     
  14. So you got suspend on lid to work? And you can recover? Could you please share what you did? Because i am on 4.6.2 and it does not work properly. Thanks a lot
     
  15. funbestCoral612

    funbestCoral612 New Member

    Well I am on stock Kubuntu 16.04(fresh install not upgrade) and I closed my lid and it suspends. I open the lid and it resumes. I did nothing except run those commands I posted above.
     
  16. Thats's strange.
    I am also on kubuntu 16.04. I fixed my wifi. Then i upgraded the kernel to 4.6.2.

    You are running blade 2016 right? Not the stealth. And does your reboot/shutdown work properly?

    Mine just goes black screen after i open the lid again.
     
  17. funbestCoral612

    funbestCoral612 New Member

    No I have a 2015 model.
     
  18. I see. That might be it. Thanks anyways.
     
  19. Makyura

    Makyura Member

    Hello everyone,

    I've been following this thread for a few months, but just got into the fight with Ubuntu a few days ago.

    After about 10 reinstalls, trying 14.04, 15.04, 16.04, Elementary OS (based on 14.04) versions of Ubuntu, a few 3.x and 4.x kernels I'm finally happy with this setup (16.04 ubuntu and 4.6.0).

    TLP, powerTOP, bumblebee and a FHD resolution made me hit 5 hours of battery life altho I use macbuntu skins, didn't get rid of animations and use Plank and Albert tools (note that my battery's lost 10% health so it ain't bad at all) browsing through Opera in battery saving mode.

    Everything works (except for the thing that sometimes, while I shut down the PC, it suspends instead and I need to weak it up and turn it off for good) except trackpad gestures, which makes me mad.

    I can only get it to scroll up-down and right-left, or launch the launchpad using a 4 fingers gesture, no zoom-in/out, no back-forward nor any other three/four fingers gesture works.

    I've tried everything I could find on the net and nothing ever worked for me; did anyone ever find a way to get Synaptics drivers/whatever Ubuntu can use to work for good?
    If yes, could you please share it?

    Note that I tried the fix posted my _ramsay_ in page 1 and the Alex Cabal one (to be found on his blog) already.

    Thank you very much!
     
  20. I have a razer blade stealth and managed to get the suspend on lid close to work, I'm guessing it's almost the same issue, maybe needs a slight adaptation. Maybe this saves you the half day I spent getting it to work lol!

    https://www.reddit.com/r/razer/comments/447vrn/razer_blade_stealth_linux/d4zfspx

    As I mentioned in another thread the parent also posts a different solution that works (though not with systemd-logind).
     
    supaevensteven likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >