Linux on Razer Blade Pro

Discussion in 'The Linux Corner' started by nauce, Jan 11, 2017.

Thread Status:
Not open for further replies.
  1. Hi friends!

    I am the proud owner of an awesome new Razer Blade Pro (2016).

    I want to install Linux on it, but I am having trouble because of the Raid 0 configuration. The Ubuntu (16.04) installer won't show any installable hard disks. This is even with mdadm installed.

    I have searched everywhere to learn more about the way that the RAID 0 is setup with this machine, but I cannot seem to find anything. I know that I can turn it off in Bios (going to AHCI mode), but this would eliminate the awesome RAID 0 performance.

    In short, I want the awesomeness of RAID 0 in Ubuntu (dual-boot). How is this possible? Is there some way to get Ubuntu to see the HDD?

    And, yes, thanks in advance for suggestions about VMWare/VirtualBox and virtualization. I am currently running Linux in a VM when I'm not gaming, and I really would prefer to Dual Boot.

    Thanks in advance for any insight!!
     
  2. brainbacon

    brainbacon New Member

    You might try Fedora 25 instead of Ubuntu since it has a newer Linux kernel version. We've had good luck with Fedora and it gets updated faster than Ubuntu.
     
  3. Katana_x_II7

    Katana_x_II7 Well-Known Member

    Some people prefer debian over red hat. He came here asking for help installing ubuntu...not which OS he should use to get it to work.
     
    ldartez and propernorf like this.
  4. @brainbacon Thanks for that mention. I'd be willing to give anything a try that is a native dual-boot. Windows is pretty much untenable (for me) as it pertains to Scala, Go, Elixir, and JS development.

    @Katana Thank you for preserving the integrity of what I came here for.

    I sincerely hope someone on the Razer team can chime in. In the end, I'm sensing it's a driver issue related to the MoBo. (Or, at least, the Raid chipset?)

    In any case, I know the core purpose of a machine like this is for gaming. But when you consider the folks for whom this is in-budget, I have to imagine that Software Development over-indexes as a profession. No? =]
     
  5. I gave up trying to get dual boot working and went with VMWare instead. You can still give it plenty of dedicated resources with this beast.
     
  6. brainbacon

    brainbacon New Member

    @Katana Wow. I'm not suggesting anyone change their philosophical viewpoint on which Linux distro is best. I'm just saying this one might work because it has a newer kernel. He came here asking for Linux in dual boot, not specifically Ubuntu. I'm not an Ubuntu expert, so I'm not going to tell him how to recompile it with the newer kernel. I can only suggest a distro that has it already.
     
    somnify likes this.
  7. I appreciate any insight I can get at this point. Has anyone out there gotten the Razer Blade Pro (2016) working on ANY flavor of Linux?

    Thanks in Advance!
     
  8. syscrusher

    syscrusher Member

    Several of us have been discussing this on another thread. Take a look here: The Razer Blade Pro and in following posts.

    You might also want to check this: https://insider.razerzone.com/index...upgrade-guide-windows-10-clean-install.19004/

    Specifically, it's a hardware modding guide, but talks about how to get rid of RAID 0 in BIOS settings. The recognition of the Intel Rapid Storage (IRS) subsystem was the biggest problem I had when I was testing a quick Linux thumb drive boot.

    As a sysadmin, I really don't recommend RAID 0 for any data you care about, unless it is nested with another RAID level (usually 1 or 6) for redundancy. You can't do nested RAID with just two physical drives. In a system with NVMe SSD, you'll get great performance without RAID 0. Go for JBOD or RAID 1 instead. In Linux, you can go JBOD and span with LVM2 if you want, although that introduces some of the same concerns as RAID 0 unless you hand-tune the LV to PV affinity in your VG.

    I wrote a long letter to Razer Support a couple of days ago suggesting they consider offering a business-tier paid support plan with accelerated repair priority and priority phone support. I, too, am in this market for a professional workstation because part of my work involves data analysis and CAD-like functionality. The specs that make a premium gamer laptop also make a great workstation for 3D engineering and simulation, but you need business-grade support.

    One of the points I raised was exactly this: Professional users are very likely to be the people most likely to be willing and able to spend this kind of money on a laptop, because it is a tool and not a toy.
     
    Last edited by a moderator: Jan 23, 2017
    Hactar88 likes this.

  9. Agree there, I'm a developer and a gamer and I switched to the Blade Pro because the latest Macbook is subpar for their pro users.
     
    passabilities, Atlas2256 and Hactar88 like this.
  10. @Syscrusher Thank you so much for the thoughtful posting and insight here. I know that my company would be totally interested in looking at Razer (over System76, which is what our guys currently use when not using MBPs.)

    In any case, I know I should probably just suck it up and "eat it" as it pertains to RAID 0, but it's been psychologically hard for me. I hate the idea of losing speed to use Ubuntu. (Part of me then goes down the road of just considering downgrading the machine entirely to the just the Blade.)

    I know that Raid 0 doesn't necessarily scream data safety, but I'm not super concerned, given my heavy use of Git and the cloud for anything. If my drives totally failed, I'd be losing minutes of WIP, which is acceptable to me.

    @Sythic Exactly!!! I feel like the only two things that matter on a machine are gaming and coding. I presume I'm not the only one who thinks this way?

    Yucky, I really don't want to go down the road of exploring a Dell XPS 9560. (God forgive me.)
     
  11. nathanvollmer

    nathanvollmer Member

    Just curious, have you tried using another distro native, like a red hat distro? If it works for red hat but not debian, that might give some insight into what's causing compatibility problems.
     
  12. syscrusher

    syscrusher Member

    My wife has a System76, which she bought last year, and loves it. They'e a Clevo (with customizations) reseller, so you could also look at companies like OriginPC, XoticPC, and HIDevolution.

    For what you're doing, are you really gaining that much speed in terms of your user experience? If you are heavily coding (as I am) most of your files are measured in single-digit megabytes (object) or fractional megabytes (source). An NVMe drive without RAID will already push over two gigabytes/second sustained.

    If you really want to get that RAID recognized in Linux, there are drivers out there. Look into intel_irs.ko and friends. I wasn't able to get this working on my RBP, but before I even started I had a known failure of one SSD, so I was just playing around on an already-dead machine with nothing to lose.

    Although there is also all your work getting things set up the way you want, customizing your desktop, etc. The nice thing about Linux, of course, is that with no registry involved you can back up almost all your settings as normal config files from /etc, /var/lib, and your home directory.

    I will posit this, though: Cloud notwithstanding, if you have enough local data that you even care about the performance difference between NVMe RAID 0 and NVMe JBOD, then you have a significant amount of local data, and you should care even more about data integrity. Restoring terabytes from backups is Not Fun, no matter how good those backups are.

    On the Windows side with your games, again think of your time if you have to do a complete restore. I get most of my games from Steam, so "reinstalling" is a no-brainer -- but it's also many, many hours of downloading bits, even with fairly fast Internet. And in some of my games, such as Elder Scrolls and Fallout, my setup is heavily modded, which takes hours per game to set up. In Elder Scrolls, I actually create mods, which means many more hours of setup time. In fact, I deliberately run my modding environment in a virtual machine -- and damn the performance -- precisely because just one time a system failure wiped it out. I had full backups of everything, but it cost me all my spare time for almost a week to get it back the way I wanted it. I play natively but develop in a virtual machine.

    I've ranted long enough here. As someone else -- very rightly! -- pointed out above, this is your system, and you have every right to configure it as you wish. I am not meaning to be argumentative, but I wanted to urge you to consider the entire "big picture" about whether RAID 0 is really worth it in your situation. You're a programming professional -- how many times do you factor "maintainability" of your code higher than something else that might be more glamorous, such as a new feature? My advice, worth exactly what you paid for it, is to play the long game here. :)
     
  13. .Z4x.

    .Z4x. Active Member

  14. I have Arch Linux running on my Blade Pro 2016. It's still not perfect, but works good enough to be my main OS. However, I got rid of the RAID0. It makes so little sense that to be honest I'm kinda disappointed that there wasn't an option to remove it while ordering.
     
    Bob Dobbs and Syscrusher like this.
  15. JRBobDobbs

    JRBobDobbs New Member

    Volcacius, when booting your Blade Pro are you able to choose between Arch Linux and the Razer-installed Windows?
     
  16. Yes, I have windows on one SSD and Arch on the other. Both with GPT partition tables and UEFI bootloaders, so i can simply boot the one I want from the bios built in boot manager.
     
    javaman and Uhl0x like this.
  17. Uhl0x

    Uhl0x New Member

    Awesome new to see Arch supports this beast. I am looking to move to Arch Linux and knowing the Blade can handle this makes it even better.
     
    Atlas2256 likes this.
  18. I had to install it through an ubuntu 16.04 live tho, when I tried the arch live install didnt boot
     
  19. I actually stuck Ubuntu on the 128GB SD card and dual boot to it from the BIOS boot menu

    Anyone find a way to disable tapping on the touchpad in Ubuntu? I don't mean disabling it altogether either, just tapping. I believe the root cause is it is being seen as a mouse device. I haven't had any luck with any of the Synaptics stuff either.
     
    Last edited by a moderator: Mar 27, 2017
  20. fillway

    fillway New Member

    @Syscrusher

    I am looking to have the RAID 0 visible in Linux to repair some issues with my Windows partition. Have you (or anyone else in these forums) had any luck in getting the orginial Razer partitioned boot drive to appear in any linux distro I could then compile testdisk and the like to?

    I am bringing point clouds from laser scans and rendering them into models so they can be viewed in Unity and then in the Oculus, and stupidly didn't backup this system (first time I EVER haven't had a backup) due to my excitement in how fast and stable it was. It was just progress progress progress- then fail, after about a month. Lost every model, every project file, everything :'(. Would very much like to get it all back.

    The RAID has not failed, and it was totally my fault in treating a Windows build like OS X and preforming a hard power off at the wrong moment- so used to the Mac after all these years without a PC...

    Thanks!!
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >