Linux Support on Razer Blade Stealth 2019

Discussion in 'The Linux Corner' started by _alxk, Jan 5, 2019.

  1. _alxk

    _alxk New Member

    I'm considering getting the new Razer Blade Stealth 2019.

    Can I expect Linux support to be decent?

    Information on running Linux on Razer's is rather sparse in general, and I've seen inconsistent reports.
     
    purplexed9 likes this.
  2. purplexed9

    purplexed9 New Member

    I am planning to buy one early February and get linux on, just waiting to see whether the infant illnesses can be fixed (e.g. crackling sound from speakers)
     
  3. Neergaard

    Neergaard New Member

    I've installed Ubuntu 18.04 on the 2019 RBS. It works fine, EXCEPT for the fact that I don't think the fans are running. The computer runs hot (not very hot, but hotter than normal), and the battery life is severely compromised as a result. Have yet to find a solution though.
     
  4. JvlaOtur

    JvlaOtur New Member

    Hello hello!

    I'm typing this from a stealth blade 13 2019, booted from USB Ubuntu 18.04.01

    wifi is fine,
    touchpad is fine
    fans seems to works fine
    screen brightness buttons works fine
    keyboard backlight works fine
    volume keys works fine

    I have a problem with crackling noises when I run windows 10 on this machine, so booting with linux was a way for me to see if the problem was hardware or software related. Since it does not have the crackling sound in the usb booted ubuntu, the crackling noise from the speakers seems to be software related to windows10 and then specifically the drivers for the soundcard from what I can tell.
     
    Panaman likes this.
  5. mdaly001

    mdaly001 Active Member

    Are you running one with mx150?
     
  6. JvlaOtur

    JvlaOtur New Member

    Hello mdaly001!

    Yup, Im running it with the nvidia drivers on the mx150 gfx card on ubuntu 18.04.01(Budgie Flavour)

    When I run this in the terminal, then I get this:


    ~$ ubuntu-drivers devices
    == /sys/devices/pci0000:00/0000:00:1c.4/0000:02:00.0 ==
    modalias : pci:v000010DEd00001D10sv00001A58sd00001000bc03sc02i00
    vendor : NVIDIA Corporation
    model : GP108M [GeForce MX150]
    driver : nvidia-driver-390 - distro non-free recommended
    driver : xserver-xorg-video-nouveau - distro free builtin

    I installed it by running this guide.

    https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux
     
    Last edited by a moderator: May 15, 2019
  7. mdaly001

    mdaly001 Active Member

    JvlaOtur likes this.
  8. JvlaOtur

    JvlaOtur New Member


    Glad I could be of assistance for you! =) It was strange though, since the 19.x versions did not behave as nice as 18.04.01 did... Took me a day to go through each of them... but it was very much worth the time spent. =)
     
  9. Oh good to know, have the same: on Win10 crackling noises but not on Ubuntu 18.10
    Only thing is not working properly for me on Ubuntu is power management: I can only get like 3h
    Everything else works out of the box: Bluetooth, Camera/Mic, Pad
     
  10. JvlaOtur

    JvlaOtur New Member

    I have not seen any power management problem with my installation.

    I installed the deepin linux 15.9 dist 3days ago after running ubuntu budgie 18.04.01.

    The deepin 15.9 seems to work just as good, but with a even nicer ui. But I have not enabled the mx150 driver in that installation... and I feel that I have plenty of battery left after 3 hours of usage.
     
  11. Soapdroid

    Soapdroid New Member

    Last edited by a moderator: May 15, 2019
    Panaman likes this.
  12. jchavezar1

    jchavezar1 New Member

    Did you have any problem with touchpad in Ubuntu? Specifically with web browsing going back and forward swiping with 2 fingers ? And also any hang on reboot or shutdown? I have tried to run it on Manjaro (Arch Linux) and it seems like something is not working there, reboot hangs seems to be something regarding the video driver but the problem is that in blade stealth we have hybrid card (screen/monitor is attached directly to Intel) and the other things are Nvidia, so it's a kind of noisy ...
     
  13. gauntface

    gauntface New Member

    I just got the 13 blade stealth and can't run Ubuntu from a USB stick, I get the following error:

    > Unable to find a medium containing a live file system

    Any ideas on how to fix this? I've tried altering the BIOS settings that might affect this (secure boot etc) but nothing seems to fix this problem.

    Turns out using a different USB stick fixed my problem.
     
    Last edited by a moderator: May 15, 2019
  14. JunleLu

    JunleLu New Member

    Unplug the USB when ubuntu loading screen appears, then plug right back in.
     
  15. xander12093

    xander12093 New Member

    I have been running Ubuntu Budgie on my Early 2019 Blade Stealth - 4K since the day I got it. Below are my thoughts after running this as my daily driver for more than a month:

    1. At first boot, the polychromatic keys were stuck changing colors.
    - This was a simple fix after a quick Google search and installing the software.
    2. Battery life was poor and the laptop was getting warmer than I thought it should for just simple browsing
    - This can mostly be mitigated by opening the Nvidia X Server settings and changing the profile to use the integrated intel graphics instead of the MX 150.
    3. The scaling on Ubuntu on the 4K screen isn't the best. Your options are 100% or straight to 200%. However, lowering the resolution slightly and changing to 100% scaling gave me not only better battery life, but also better screen sizing. My personal preference has been 3200x1800. It is still very sharp but if you want better battery / scaling yet I also liked the look of 2560x1440.
    4. Audio on Linux, in my experience, has never been as good as Windows. I rewrote the pulse audio config file to help improve this. I still wouldn't say that it's as good as Windows sound, but significantly better.
    - rewrite this file: /etc/pulse/daemon.conf with the below lines:
    default-sample-format = float32le
    default-sample-rate = 48000
    alternate-sample-rate = 44100
    default-sample-channels = 2
    default-channel-map = front-left,front-right
    default-fragments = 2
    default-fragment-size-msec = 125
    resample-method = soxr-vhq
    enable-lfe-remixing = no
    high-priority = yes
    nice-level = -11
    realtime-scheduling = yes
    realtime-priority = 9
    rlimit-rtprio = 9
    rlimit-rttime = -1
    daemonize = no
    flat-volumes = no

    save the config and run "pulseaudio -k" (not as su) followed by "pulseaudio --start"
    5. When using the Nvidia MX150 and playing games, even when connected to the power adapter the battery drains. From my understanding, this is a hardware problem and is the exact same with Windows as well.

    Overall I am very happy with this device. I am coming from a mid-range Surface Laptop that I was also using Ubuntu Budgie with which I will say, was a rough time getting everything working on. I was pleasantly surprised with the minimal adjustments needed to get Linux fine tuned to my liking. I am also impressed that there's a Linux dedicated forum on the Razer website.

    To conclude, if you are looking for a powerful ultrabook that can run Linux with ease, this laptop gets my full endorsement.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >