Mouse cursor freeze/stutter when switching profile

Discussion in 'Razer Support' started by RobotMan91, Mar 10, 2022.

Thread Status:
Not open for further replies.
  1. RobotMan91

    RobotMan91 New Member

    I currently have the Razer Naga Trinity - wired. Though, this issue (that i'm about to explain) persisted with my prior mouse too (Naga Hex V2).

    Ever since I switched to Synapse 3.0 several years ago, from day 1, whenever Synapse switches the active mouse profile, there is about a 1.5 second freeze/stutter of the cursor where it visually appears unresponsive. Because of this, i've had to completely stop using any automatic profile switching (program linking) because it is too frustrating with the constant freeze/skip. But this doesn't even completely prevent the issue from persisting.

    I have 1 main profile that I use for most programs/tasks (browsers, file explorer, videos, text editing, etc.) and will manually switch to a profile during a game. Thing is, Synapse will constantly swap between profiles whenever you switch programs/processes on it's own via a "feature" cuz it thinks it is making your life easier. This is when going from a game to a browser, then again back to the game profile when going from browser to notepad, then again and again over and over as you navigate various programs/processes on ur pc.

    Only way to stop it from doing so is by manually switching to the default profile while the game profile is active (in my example). To be clear, I can see the benefits of the auto profile switch, and it was semi useful sometimes back on Synapse 2.0.

    But with this skipping/freeze issue, i've gone to drag 1 single file over from a folder to say an email or browser and next thing I know my pc is copying an entire drive to some place. I can list many more examples of how this has caused annoyances.

    I've put up with this all these years cuz for the most part, I like synapse but since i'm once again experiencing unintended double clicking with my mouse (and Razer wouldn't cover the cost since i was about 6 weeks outside of warranty) i'm considering switching to another brand and software.

    But i'm surprised i haven't heard about this issue from others or been able to find a post about it now that synapse 3.0 has been out for a while. I submitted an in-program feedback in the beginning and was hopeful it'd be fixed by now. Anyone else experience this problem?

    TLDR: Mouse cursor freezes/stutters/skips/lags for about 1.5 seconds whenever the mouse profile is switched. Anyone else experience the same thing? Is there a way to completely turn off the automatic switch to the previously used profile when changing the active program?
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Did you try resetting the mouse via the Razer Synapse 3.0's settings? Please replicate the behavior while logged as a guest user account. Let me know if it works.
     
  3. RobotMan91

    RobotMan91 New Member

    I don't know if i've ever reset to factory defaults but I just logged out of my account and continued as a guest and experienced different results.

    First of all, when on a guest account, a new default profile is populated but there are still 2 profiles i've created shown in the list, which i presume are just being read from my drive (they're not stored on the internal profile storage fyi). But I added a 2nd default profile and tested switching between the 2 default (no rebinds/configuration edits) and received zero lag/stutters during the switch.

    I then added 2 basic rebinds on the 2nd newly created profile, changing 2 buttons to be a keyboard key. After doing so, there a very slight stutter of about .2 seconds whenever switching to or from the profile with the 2 rebound buttons. I then added 4 more button rebinds and am getting closer to the 1.5 stutter when switching profiles.
     
  4. RobotMan91

    RobotMan91 New Member

    Thanks for the response and support btw.
     
  5. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for performing the suggested steps. You can also try replicating the issue while connected to a different USB port or computer. Ensure that your device is connected directly to the computer's USB, not on a hub.
     
  6. RobotMan91

    RobotMan91 New Member

    Sure i'll try that in a few days or so. I am about to build a completely new pc as soon as the last component arrives. But tbh, I assumed this was normal behavior but sounds like it isn't, based on your responses, which makes me hopeful that it can be fixed. I'll report back afterwards. Thanks
     
  7. neoDD69

    neoDD69 New Member

    This don't works.
    The problem is "known", I signaled to Razer dozens of monts ago, but I suppose that the software team is not skilled enought to solve this issue ...
    it's a communication problem from Razer service to the device (Mouse, keyboard, and so on).
    I use Razer device to work, not only for gaming, and I switch frequently from Visual Studio and other apps and Synapse lags every time and in the few weeks .. it seems go crazy and after some hours of works instead of doing the configured "TEXT FUNCTION" it play paste for every key that is congiured for a text function !!!

    I'm an iper-full-stacked and ultra-senior DEVELOPER and this is a clear BUG in Synapse software.

    Razer guys : please inform your dev team and push to solve this issue (there are a lot of posts that can linked to this issue on your SW)

    In short terms: IMHO, SYNAPSE is destroying razer's reputation.
    Cheers,
    Davide
     
  8. RobotMan91

    RobotMan91 New Member

    Hey thanks for the response and confirming. I also use the device for work and am constantly switching programs, which as I stated, just completely makes any custom program/profile linking un-feasible. And ofc, makes me try my best to not even setup multiple mouse profiles. I've resorted to using 1 profile for the most basic functions (copy, paste, ctrl, shift, backspace, etc.) and use the keyboard with many many Razer Shift binds.

    Do you by chance know how to at least prevent Synapse from automatically switching to the previously used profile when you change the active program to another, after manually changing a profile?

    I can't remember for certain, but think Synapse 2.0 had the option to disable it. Or I may just be remembering when an update introduced the "feature" into 2.0, and that there was never an in-program togglable option to disable.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >