Mouse DEATHADDER V2 not detected by Synapse in W11

Discussion in 'Mice and Surfaces' started by batgiorgio, Nov 15, 2022.

  1. batgiorgio

    batgiorgio New Member

    Hi all, I have several Razer devices connected to my PC and I realized that only the mouse in question is not recognized by Synapse. Well, I've followed any guide on razer sites, google and youtube, but nothing seems to work.

    Uninstalled drivers from device manager, clean reinstalls of Synapse, after deleting all the dirty files it leaves on some directories (Program Files, Program Data, Windows...)

    I really tried them all, I also sent the report of the dedicated tool from Razer, but no errors are detected.

    To make sure that the mouse wasn't the problem, I tried it on another PC and it's recognized regularly there.


    synapse3.png device_manager.png

    Any suggestions?:frown_:
     
    pancholr and JR_1018 like this.
  2. FiszPL

    FiszPL Well-Known Member VANGUARD

    Did you've tried to clena reinstall Synapse?
    1. Uninstall Synapse
    2. Download & run this tool: https://rzr.to/Tf53xj to remove any razer drivers/leftovers
    3. Then restart your PC
    4. After reboot install Synapse again (as administrator).
    If this will not work - try manually updating drivers - choose C:\Program Files (x86)\Razer Path, then you'll have few PIDxxxDRV folders - there are .ini files inside, so if you'll choose properly, on the next screen you'll see that it's dedicated driver for DeathAdder V2
     
  3. batgiorgio

    batgiorgio New Member

    It worked! I followed all the points to the letter and finally the mouse is recognized!

    A thousand thanks!
     
    FiszPL likes this.
  4. john14073

    john14073 New Member

    I have been running into similar issues - your fix did not work for me. I made sure to uninstall Synapse before running the script, restarted, then reinstalled Synapse.

    Here is my post I have been commenting around:

    I am also experiencing this issue. We are not the only ones either. I have had this mouse for a little over two years and this seems to be a new issue.

    This is a comment I just made on another post very similar to yours:
    "
    +1 I am also experiencing this.

    I updated Razer Synapse 3.0 and now it doesn't detect my Razer Deathadder v2. Windows 10 claims there is a "driver error" just like OP.

    I have repaired, uninstalled & reinstalled, and modified Razer Synapse 3.0 several times each.

    I tried removing the device from Windows while the mouse is unplugged and Razer Synapse 3.0 not-installed, followed by reinstalling Razer Synapse 3.0 and finally re-plugging the mouse in and that did not result in a different outcome.

    Razer Synapse 3.0 behaves as if no Razer devices are plugged into my PC. As a result, the Calibration and Lighting tabs are missing and I am not able to see the controls for the mouse at all.

    As if this whole thing wasn't weird enough, my mouse now has the most unique lighting behavior I have witnessed on a device like this. The LEDs periodically illuminate, only flickering. When they do illuminate, it does the default Spectrum Cycling. When I first observed this I thought, "Oh, a wire is disconnecting and the lights are slowly going out." Until I realized the mouse is only flickering when my PC outputs audio. The mouse drivers are literally reacting to music and my friends in discord. It is the weirdest thing.
    "
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >