My Electra V2 7.1 USB headset

Discussion in 'Razer Support' started by Back2VR, Aug 3, 2021.

Thread Status:
Not open for further replies.
  1. Back2VR

    Back2VR New Member

    Today synapse 2.0 doesn't recognize my headset. Do you have any idea what can be the solution? I tried to unplug it, I tried reinstalling the synapse none of these seemed to work. I also can't find it in Windows 10 USB devices.
     
  2. Razer.Xenon

    Razer.Xenon Active Member Staff Member

    Does the Device Manager still detect the headset? For now, let’s uninstall the headset drivers by doing the following:

    -Press Windows + S on your keyboard to open the Search bar.
    -Type in “Device Manager” and hit Enter.
    -Go to Audio Inputs and Outputs.
    -Right-click on your Razer headset and select Uninstall device.
    -To completely uninstall the drivers, restart your computer.
    -The drivers are automatically installed on your computer after a restart.

    If the issue persists, PM me the serial number of your device. I can use it to verify its model and look into other possible solutions.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >