My games lag on my Razer Blade 2019

Discussion in 'Systems' started by David0184, Aug 3, 2020.

Thread Status:
Not open for further replies.
  1. David0184

    David0184 New Member

    Hello,
    I have the Razer Blade 15 Advanced (Early 2019)
    I've enjoyed playing on it from the past 8 months but from the last 1 month, all of the games have started to lag like crazy. They run great for a couple of minutes and once the laptop heats, it starts to lag.

    I checked my cpu and gpu temperatures and it seems like overheating is causing the lag.
    The issue persists on both gaming and balanced mode.
    I've attached the pictures of temps etc when idle and when under stress. I used watch dogs 2 for the temps under stress.

    I was reading about undervolting on many forums but I am not sure if I should do it or not.

    Specs:
    i7-8750H
    32GB RAM
    Samsung 970 EVO 1TB
    RTX 2080 Max-Q

    Note: I upgraded the RAM and SSD 9 months when I got the laptop so that is not causing this issue I think.

    If anyone has any input, it would be greatly appreciated.
    Thank you.

    Screenshot (3).png Screenshot (6).png
     
  2. M-S-G

    M-S-G Well-Known Member

    Ok, currently the room temperatures should be much higher, surely you have 26°C and more in your room. So the device heats up much more. Have you ever removed the base plate and cleaned the fans with compressed air or a cotton swab?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >