My Kraken 7.1 V2 and synapse not working.

Discussion in 'Razer Support' started by Rafe_, Jan 12, 2019.

Thread Status:
Not open for further replies.
  1. Rafe_

    Rafe_ New Member

    I installed Synapse 2 and it installs just fine. But when i open it up all i see is the following:

    [​IMG]


    When i right click the Synapse tray icon i see the Kraken 7.1 V2 in the list and i see it in the device manager which reports that the Kraken 7.1 and that it is properly installed but synapse wont do anything else but what you see in the embedded image from my desktop.

    But i cannot select the device from the audio/volume tray icon as it is not even there to select.

    I have connected the kraken to every USB port i have on my system (Both solo and combined with other devices) , No USB hubs just directly into my motherboard's USB ports.
     
  2. Rafe_

    Rafe_ New Member

    This is the support forum right? How come i am not getting any response from support on this?
     
  3. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Hi @Rafe_, how does your headset appear in the Device Manager? Can you put up a screenshot of that?
     
  4. I too would love to know why my Kraken 7.1 V2's will not show up in Synapse... They were working 100% fine until today, they just randomly stopped working. I can right click on Synapse in my task bar and it shows them there, if I click on it, nothing happens...
     
  5. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Let me help you isolate the issue. Send me a PM with the serial number of your headset and let's take it from there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >