My Naga Trinity's scroll wheel won't scroll, but its not stuck.

Discussion in 'Razer Support' started by Longinus-209, May 26, 2021.

Thread Status:
Not open for further replies.
  1. Longinus-209

    Longinus-209 New Member

    The scroll wheel isn't stuck and the tilt and press functions work for scrolling, but using the wheel itself isn't being detected or something like that. I've tried to re-install drivers and synapse 3 itself and tried using different USB ports. I've also tried using my air duster to blow out anything but that hasn't done anything either.
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    You pretty much did all the troubleshooting already, so this is highly likely a faulty rotary encoder. Please send me the serial number of the mouse. I can use that to verify the warranty status of the device. Let's go from there.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >