Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

My RAZER Blackwidow X Chroma "u" key stopped working after 2 days!

Discussion in 'General Discussion' started by Shhonne, Apr 7, 2017.

Thread Status:
Not open for further replies.
  1. Shhonne

    Shhonne New Member

    I am very disappointed...

    Recently (2 days ago) my RAZER Blackwidow X Chroma came in the mail. I was super hyped and it was great. Really happy and all. until today, today I was just gaming when the keyboard's "u" key stopped working.... I panicked! I kept pressing it but nothing and I even removed the keycap and it seemed all fine. I restarted my computer. When it asked to put my password in, it worked! I felt calm again until I tried searching something on google and AGAIN it didnt work!! Now Im extremely annoyed on RAZER's part, Im having to use my 5 year old DELL keyboard which works beautifully no problems! I would really like a refund, or a solution to this.

    Oh and Im using the AZERTY keyboard.

    I would desire an explanation as I am very pissed!
     
  2. --Kaos--

    --Kaos-- New Member

    Tbh i wouldnt be as pissed off as you sound . End of the day its a keyboard. I agree frustrating but if you go about it the right way im sure that Razer would be happy to replace it. Gotta love the warranty.
     
  3. RaptureHearts

    RaptureHearts Gamer Geek Girl

    Just like @--Kaos-- says, our support team would be more than happy to assist you. Contact our team at http://rzr.to/help so they can help you. Our team would be more than happy to replace your keyboard for you.

    Since Razer Insider is not a support-related forum, I will be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >