Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

My Razer Orbweaver Chrome, has certain keys, not working

Discussion in 'Razer Support' started by ironfist7913, Jul 18, 2018.

Thread Status:
Not open for further replies.
  1. ironfist7913

    ironfist7913 New Member

    Hello, i hope to get some help here on what the problem can be.
    After one month keypad 20 started acting up. After two months keypad 1 joined.

    Then i had a long gaming break and put it on the shelf. Started the pad up..
    Now its 1,6,16,17,18,20.
    Making its really awkward to play. Some of them works but i have to push them several times or hard.
    some of them don't work at all.

    Anyone got an idea what the problem is?
    I do not have the bon
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello. Have you tried plugging it into another PC to see if it does the same?
     
  3. ironfist7913

    ironfist7913 New Member

    Hello. Yes i plugged it into every usb port i have, and tried it on another pc as well.
    I figured out some of the problem, something odd.
    When i push the doll keypads down and pretty hard from the right at the same time, they work.
    They need decent push from the side to work, like something shifted down under. i dont know..
     
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Oooh. Have you tried cleaning under the keys? You can do so by holding the unit upside down and/or using compressed air from a can.
     
  5. Predator5

    Predator5 Well-Known Member

    Seems like it's a mechanical issue (pun intended).

    As Razer.RedPanda said, I would recommend taking of the keycaps, pressing the switch in and blowing it with compressed air to hopefully get any dirt out of it.
     
  6. Tixtremer

    Tixtremer New Member

    Hi there,

    I think i got the same problem but i do not understand your explanation because of the fact that English is not my main language but i will try to explain my problem and i really hope someone has a solution.

    With my orbweaver i noticed that sometimes i responded to late to some situations when i was certain of pressing the good key at the good time. Then i started testing and noticed my key number 13 is not responding all the time. if i push it strongly and push it forwards and backwards, it responds and then it doesn't.

    I thought the only solution was replacing the switches on the printed circuit board so i bought the new tartarus v2 but i still miss my orbweaver every day. For me it feels like the orbweaver was the pro edition and the T v2 is just the next best thing.

    Thank you in advance for your reply's
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >