My Wolverine V2 Chroma Will Not Turn On After I Updated the Firmware

Discussion in 'Razer Support' started by centralZaffregeo592, Apr 9, 2022.

Thread Status:
Not open for further replies.
  1. centralZaffregeo592

    centralZaffregeo592 New Member

    I bought this controller a little over a month ago to play on Xbox. It worked just fine. I took good care of it and it showed zero issues until now. I go to change the sensitivity on my joysticks through the app and it ask me to update the firmware. Takes a minute and then my controller just shuts off. I’ve unplugged everything, restarted my Xbox, and tried a different cord. I don’t have any other controllers so I need to figure this out soon. Also, I would really like it if I didn’t have to buy a new one.
     
  2. Were you able to fix it?
     
  3. Batepronto

    Batepronto New Member

    fixed?
     
  4. Razer.Zionzedd

    Razer.Zionzedd Yes, My lord? Staff Member

    Hi guys! Please PM me the serial number of your controller so I can look into the model specifications and start a case. I will forward it to the Engineering Team so that they can check the firmware issue.

    *Thread locked to curb conversation to PM.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >