Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Nabu watch forged edition is not syncing with the nabu android app

Discussion in 'Razer Gear' started by JR0nin, Mar 22, 2019.

Thread Status:
Not open for further replies.
  1. JR0nin

    JR0nin Well-Known Member

    Hey guys,

    So today i got my Razer Nabu watch forged edition. Unboxed it, charged it and installed the Nabu app on my phone (One Plus 6T | Android version: 9).

    After installing the Nabu app i gave all the permissions and switched on the location and bluetooth post which tried adding the Nabu watch from the app home screen.

    The watch gets found/detected on the initial screen, long pressed which showed me the 4 digit number and entered the same in the app. Then it connects and starts the "syncing" screen. It goes on showing the syncing message for almost 30s - 60s and throws message "syncing failed, error".

    I tried syncing it multiple times without no luck of getting any further.

    Also tried,
    - uninstalling and reinstalling the app
    - re-logging in to the app
    - gave the permissions again
    - switched off/on the location and bluetooth

    Not getting any further, can somebody help me please to get this sorted.

    Thanks in advance.
     
    pancholr likes this.
  2. Predator5

    Predator5 Well-Known Member

    Hello,

    Have you tried contacting Razer Support via chat or email?
     
  3. JR0nin

    JR0nin Well-Known Member

    Hello, yes i have raised a case with Razer support as well in the meanwhile.

    Just wanted to know if somebody had a previously used or knows quick workaround for the same.
     
  4. .Surf.

    .Surf. Well-Known Member VANGUARD

    I had some issues with the Nabu X, it wouldn't find it on the bluetooth list of devices and therefore wasn't able to sync it with the application, but i just sent it to RMA and get another one back. As for the watch, i have it for more than over a year and haven't had sync problems. I hope you do know you need to have internet connection in order to sync it. Other than that i can't really help you much, it's quite an old piece, problems are expected to appear and the most helpful way is to talk to support guys.
     
  5. JR0nin

    JR0nin Well-Known Member

    Hey, yes of course the sync only works with an internet connection. So i had a check with the Razer chat and it seems the Nabu app is not supported on Android version higher than 7 and i run on Android v9(One Plus 6T).

    Anyways, the Razer support team is looking into it with my case and waiting for an update if there's any other workaround for this.
     
    0V3R_K1LL likes this.
  6. .Surf.

    .Surf. Well-Known Member VANGUARD

    That is weird, cause i still can use my Nabu Watch synced with the Nabu App, and i just upgraded to Android 9 a few days ago. I don't think this should be too much of a problem, i'm inclined towards the bluetooth connection.
     
    Alfy1080 likes this.
  7. JR0nin

    JR0nin Well-Known Member

    Oh then its indeed strange, because if you run a v9 and i am also running v9 it should work on mine as well.

    Because i did try restarting phone, the bluetooth and location features and re-logging in to the nabu app. all the requested troubleshooting.

    But if it was a bluetooth issue, it should not be able to find the nabu and the 4 digit code on the nabu watch during the initiation of the setup between the phone and the nabu watch right? Hmmm...

    I use a One Plus 6T running Android V9, not sure if there's any phone specific setting which is blocking the sync between the watch and the phone, all ideas are welcome, thanks.

    I am really not sure what else i can test out to get this fixed, in the meanwhile i will also try to run it on another phone and see if its syncing, just to make sure.

    Hey, by the way i installed the nabu app, logged in and tried syncing the Nabu watch via a fiend's iphone(ios 11). And it worked :).

    So after that i logged in to the nabu app on my one plus and the watch synced indeed. I was able to customize all the settings, add/delete display options, vibration modes, alarms etc.So happy!

    But the notifications doesn't work on the watch, i tried sending test notification from the phone. It shows on the phone, though nothing on the nabu watch screen.
     
    Last edited by a moderator: Mar 30, 2019
    DRIFT_IT likes this.
  8. .Surf.

    .Surf. Well-Known Member VANGUARD

    Yea i know this thing, sometimes mine doesn't receive notifications either, whether its because it's already at maximum memory reached by the Nabu or doesn't receive at all. Thing is, when this happens, i restart my bluetooth or my nabu app, and it usually works, but seeing you have problems with sync idk how much can it help.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >