Naga 2014 stop working out of nowhere

Discussion in 'Razer Support' started by Joaokaka1998, Mar 10, 2019.

Thread Status:
Not open for further replies.
  1. Joaokaka1998

    Joaokaka1998 New Member

    Well I have the Razer Naga 2014 Blue Classic mouse for almost 2 years and it already has more than 1 month that I am suffering with a problem, from I connect it to the computer USB and after 5 or 10 minutes playing it stops running the front buttons, Scroll and optical reader.
    funny that the 12 side buttons continue to run and all the mouse lights are still on. it only comes back to work again everything when I pull the USB and I put it again only that is in that infinite loop to stop working until reconnected.
    I wanted to know what the solution to this problem is? I even re-edited the Razer Synapse to see if it worked and no use.
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello! Have you tried using it with another PC to see if the same issue persists? If not yet, please do. Let me know how it goes.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >