Nanoleaf Aurora Integration

Discussion in 'Razer Chroma' started by Hyland92, Jul 31, 2018.

Thread Status:
Not open for further replies.
  1. NimaZ

    NimaZ New Member

    The only reason I installed Razer software at all was for this. I was about to buy a ton of Chroma hardware, mouse, keyboard, headphones, everything. Now, I'm going to uninstall it all because there's no reason to invest more when one of the core integratons(Nanoleaf) doesn't work.
  2. ahlin941

    ahlin941 Member

    I got a lot of razer product. And I just bought the nanoleaf yesterday.
    The pairing tool can pair my nanoleaf. But it doesn't sync up the lighting effect with any game.....
    NimaZ likes this.
  3. NimaZ

    NimaZ New Member

    @ahlin941 That's because the integration is broken and has never worked. Despite advertising the integration on the Razer website TO THIS DAY, if you reach out to support they'll tell you that Nanoleaf "isn't supported".

    This is blatantly false advertising.
    ahlin941 likes this.
  4. ahlin941

    ahlin941 Member

    The worse thing is, it's crash all the chroma app. Which means all chroma supported game do not lighting up my razer product anymore...
    Fortunately, I find a simple way to make the razer product work again without format the pc. But the nanoleaf just wouldn't sync up, I give up lol.
  5. benxtan

    benxtan New Member

    Finally, after many hours, I managed to get "Razer Chrome SDK Service" to stop crashing on my PC.

    • Windows 10
    • Nanoleaf
    • A bunch of Razer hardware
    • Apex Legends
    • And if you have run NanoleafPairingTool.exe already
    At this point, I think I've give up on getting the Nanoleaf to work with Chroma.

    But if you at least want your Razer hardware to work with Chroma, the final thing I had to do was delete this registry entry:

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Razer Chroma SDK\Devices\SmartLighting\Nanoleaf

    You might have to delete HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Nanoleaf\AuroraDevices also just for good measure.
  6. VizardXY

    VizardXY New Member

    I received this email a few days ago.

    "Hello Jon,

    Thank you for patiently waiting for our email and we apologize for the delay.

    With the information that you have provided, and after carefully attempting to reproduce your issue, our Development Team has encountered the same issue on their end. Our team is working on a fix along with the Nanoleaf Team for this particular issue. We don’t have a definite time frame when it will be released since we'll need to collaborate with the Nanoleaf Team on the case. Rest assured, once our Development Team is able to fix the issue, it will be released via update on Synapse.

    Thank you for cooperating with us and please feel free to keep us posted.

    All the best,

    Razer Level 2 Support"

    So hopefully they are finally able to start fixing integration between chroma and Nanoleaf. I submitted this support ticket in November before Thanksgiving...
    ahlin941 likes this.
  7. benxtan

    benxtan New Member

    Here are the most recent replies I got.

    From Razer:

    "Thank you for responding and for the information.
    It was never tested before. So, it may or may not work. We still have no information on the matter.
    Hoping for your kind and quick response."

    From Nanoleaf:

    "Since we have not programmed the integration ourselves we have no transparency on what happens after Razer Chrome detects our panels. To our end, we just provided the panels as the base, how the software works and reacts with out panels is on Razer's side.

    I am sorry to hear Razer is unable to provide any further answers to you but on our end we cannot offer anything else to this matter."

    Considering the Philips Hue (i.e. third party lights) works with Chroma, Nanoleaf should work as well. There must be a bug somewhere on either side, and it seems neither are willing to fix the issue :slightly_sad:
  8. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    This just caught my attention.

    Nanoleaf Rhythm panels are NOT supported with Chroma SDK. If you have Aurora or Canvas panels and still experiencing any crash-bugs, please feel free to report back in this thread. We made some improvements for those products in January, so they shouldn't be causing troubles any more.
  9. VizardXY

    VizardXY New Member

    I think you are confused about Nanoleaf product offerings. There are only two light panel products. Aurora are the triangle panels and Canvas are the square panels. Rhythm is just a small add on that connects to a single Aurora panel to add music interaction abilities. Without the Rhythm module, the panels are the same just without music reaction abilities. The Canvas panels have Rhythm music reaction abilities built into the main controller and do not need the little Rhythm add on to react to music.

    Nanoleaf Aurora base pack -

    Nanoleaf Aurora rhythm edition (simply includes the rhythm module) -

    Nanoleaf Rhythm standalone unit -,tools,419&sr=1-7

    Nanoleaf Canvas pack -

    Additionally, the photo on Nanoleafs website clearly shows the original Nanloeaf Aurora (Triangle panels) working with Chroma:

    And for even more proof, you can see that this highlight video posted by the official Nanoleaf YouTube account a year ago clearly shows the Rhythm module plugged into the Aurora panels working with Chroma:

    These are Nanoleaf and Razer marketing materials that are out on the internet right now, and have been there for over a year. Ad yet the software has been broken for a very long time.
    ahlin941 likes this.
  10. benxtan

    benxtan New Member

    In that video... it looks like its saying that Nanoleaf Aurora with Rhythm syncs with game SOUNDS, rather than actual Chroma integration. i.e. its not going to change colours to match the loot box you've opened, rather just random colours based on sound.
  11. benxtan

    benxtan New Member

    So, do you mean that if I remove the Rhythm panel, my panels will work with Chroma?
    Will try soon and report back. Cheers!
  12. benxtan

    benxtan New Member

    I just removed the Rhythm add-on and IT WORKS!!!!
    Case closed! So happy now. I hope this works for all the rest of you guys!
    ahlin941 likes this.
  13. VizardXY

    VizardXY New Member

    You gatta be kidding me. So just having the Rhythm module plugged into the panels is what is killing the pairing tool??

    That's so silly.

    I'll test this out later today.

    I should have added that I had my panels syncing with chroma in the past. I speciffically had the music visualizer program working with a set and they worked just fine.

    Hopefully you found the issue, and hopefully razer can put out an update to simply ignore the rhythm module if it's plugged in.
  14. ahlin941

    ahlin941 Member


    I tried on overwatch and it's work perfectly! Thx so much!
    I hope this solution can help all of you guys who facing the same problem!
  15. VizardXY

    VizardXY New Member

    Yep, that's it. Working just fine in Overwatch for me now.....

    Of man that is infuriating. I've had an open ticket with the dev team since late October early November.....

    WAY TO GO.

    So to anyone reading, the fix is to literally unplug the rhythm module from your panels and it will work with Chroma again.
  16. Wow! I'm glad we've identified the source of the issue. I just hope that Razer will update Synapse so it can function with the Rythm module plugged in. It seems ridiculous to have to manually remove / plug in the module depending on what I'm trying to do.
  17. VizardXY

    VizardXY New Member


    Also, I would love if Razer could integrate Nanoleaf into Synapse the same way they've integrated Philips Hue lights and Thermaltake RGB Plus hardware. So that it shows up in the Chroma Configurator to be positioned in your enviorment.

    That would be lovely.
  18. SurNoah

    SurNoah New Member


    This still isn't working for me, I have synapse running, unplugged the rhythm panel, but when i try to pair my aurora doesn't come up. It says discovery complete select aurora but none appear, my lights are on. Can anyone help?
  19. VizardXY

    VizardXY New Member

    I would start by deleteing and redownloading the pairing program. Make sure you also delete the registery key under:


    Called Nanoleaf.

    Then try repairing. Make sure your nanoleaf is showing up in the Nanoleaf app on your phone and is functioning fine. And don't forget to put the nanoleaf in pairing mode (hold the power button until the light starts blinking) at the same time as clicking pair in the pairing tool.

    Good luck!
  20. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Glad that the workaround enabled your panels to work with Chroma again.

    Keep a look out for a firmware update from Nanoleaf which will address this issue once and for all, which will allow you to connect your Rhythm module while retaining Chroma SDK compatibility. (I did not get an ETA from Nanoleaf)
    VizardXY likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >