Nari Ultimate not visible in Synapse 3 after EVERY reboot

Discussion in 'Razer Support' started by Tsjerry, Aug 28, 2021.

Thread Status:
Not open for further replies.
  1. Tsjerry

    Tsjerry New Member

    As the title says, after every reboot of my PC the headset is not visible in Synapse. Very occasionally I can prevent it by turning on the headset while my PC boots up.

    I have already tried all the solutions I found on this forum (and others) such as: uninstalling the drivers, reinstalling synapse, put the dongle in another USB port, e.t.c.

    The only solution for me is to use the Nari Dongle Recovery tool every time I restart my pc. It's very annoying to have to run this solution over and over for a headset of this price!

    I've also tried to update the firmware with the Nari Firmware Updater, but I it doesn't seem to get past step 1? It sees the dongle but not the headset (connected via the cable).

    Is there anyone with the same problems and the permanent working solution?
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Ensure that the firmware that your trying to install is for the Razer Nari Ultimate only. Please repair your Razer Synapse 3.0 by following the steps from this link. Otherwise, send me the following:

    a. MSinfo logs
    b. Synapse logs.

    Save the files via Google Drive or any online drive account, then paste the link in your PM. I’ll be locking this thread now to divert our conversation privately.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >