Nari Ultimate Won't Turn on or Charge

Discussion in 'Razer Support' started by CaffeinatedMilk, Jan 20, 2019.

Thread Status:
Not open for further replies.
  1. CaffeinatedMilk

    CaffeinatedMilk New Member

    Pretty much the title. Headset won't turn on, and when I plug them in to charge they still will not turn on, and they won't even charge. I have tried multiple different cords and power sources that I know work, and have worked in the past with this very same headset. Not sure how to proceed.
     
  2. Mas2018

    Mas2018 New Member

     
  3. Mas2018

    Mas2018 New Member

    Same issue with mine. Won't charge but does turn on when plugged in
     
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello there guys! When did the issue start? Please PM me the serial number of your Nari Ultimate as well as the link to this thread. I'll pick it up from there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >