Need Help with BlackShark V2 Spatial Audio

Discussion in 'Razer Support' started by FounID, Oct 28, 2020.

Thread Status:
Not open for further replies.
  1. FounID

    FounID New Member

    When I use THX Spatial Audio on manual (All modes) I hear echo everytime I stop music etc...
    I want to know if this is normal and if so, a way turn it off. I downloaded THX Spatial Software and this echo thing does not happen, only if I turn it on in windows properties.

    The real problem is that I want to chat with friends and when they talk echo come too which is annoying since this ones does not have a dedicated chat channel like Nari so I have to use stereo, but then what's the point on buying these?

    Any help? Appreciate it
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Care to elaborate on what you meant by an echo? Are you hearing the same thing twice but a tad bit less volume, or are you referring to something else entirely?
     
  3. FounID

    FounID New Member

    I apologize, I'm not really able to correctly eleborate this echo thing, it is like if you ear the audio in a cinema or car garage*
    (if the sound is continuous like music I don't ear this echo, only if I stop audio or music or when people stop talking)

    I know that if I unplug the BlachShark from USB Card and plug the 3.5mm directly into the MB and use the THX Spatial Audio Software this echo does not happen, but like I said previously I can enable this sound effect in the windows sound properties (Realtek High Defenition Audio) which is the *Headphone Virtualization.

    Other test I did was plug other headset (Kraken TE) into the Sound Card and use the Spatial Audio and this echo effect happens aswell in those.

    This is really confusing for me, I Appreciate your help.
     
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Things like these are very tricky to deal with, so I'd appreciate it if you can put up a short clip detailing your THX and Windows sound settings. For now, try to reinstall the surround sound app, then use the calibration tool. Send me the serial number of the headset if the problem persists.

    *Locking the thread to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >